I have been struggling with this problem for a while. I am trying to create clouds using volumes. I have figured out settings that works great and the outcome is like I want it to be except it renders blurry!

I would like to get the cloud as sharp as possible but haven't figured out settings that helps me. Or is it so, that volumes cannot be used for sharp objects?

I am a beginner so I have not changed for example my rendering settings. I am also using hdri to get lights to the cloud - and tried it with different strengths: 0-30.

All help appriciated! Thank you!

Object Materials

Volume settings

Rendered blurry cloud


1 Answer 1


Two things that jumped out to me.

First, the noise texture has a Detail slider. This increases computation somewhat.

enter image description here

The second thing is messing with the settings in Render Properties -> Volumes. Try decreasing the Viewport and Render Step Rate and possibly increase the number of Max Steps.

This may not be necessary depending on your scene, I think it mostly helps with large volume objects but clouds are typically pretty large. This will unfortunately make volumes take a long time to render. That's the cost of accuracy.

enter image description here

Just for reference, even on this default cube sized volume you can see we run into some strange effects on the top boundary with the default volume settings. These images were both 512 samples in Cycles, no denoising.

enter image description here

  • $\begingroup$ Thank you for good tips. I tried to do those changes but unfortunately did not help much. Render time was 17 hours but result not that much better. Maybe it is not possible to create sharp cloud using volumetric? $\endgroup$ Commented Mar 16, 2021 at 8:03
  • $\begingroup$ Yikes! Yeah perhaps. You could try a solid mesh with some SSS, not sure how that would look. $\endgroup$ Commented Mar 16, 2021 at 13:44
  • $\begingroup$ Did not got that work either - maybe I need to figure this out in some other way $\endgroup$ Commented Mar 28, 2021 at 9:32

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .