0
$\begingroup$

When I use quick effects -> quick smoke to create my domain and stuff for me, I have had trouble if I made a mistake as to wether I wanted smoke or fire, and then tried to change it later. Once it is created, there seems to be no way to visually change it from smoke to fire. Even if I get all the physics working right for fire, all that renders is the small amount of smoke emitted by the flames. Setting up the solid viewport color for flames demonstrates the physics side is working because the flames do fade upward like they should.

How can I make a quick effect smoke domain have fire in it after it has already been initiated for smoke?

$\endgroup$
4
  • $\begingroup$ Good question. I once noticed the same exactly issue, and could never figure out what the problem was. This feature worked as expected in 2.79, and seems not to have worked ever since. $\endgroup$
    – R-800
    Mar 14 at 17:43
  • 1
    $\begingroup$ Probably the material cause this problem. Try to append it from a working blend file. $\endgroup$
    – FFeller
    Mar 14 at 17:59
  • $\begingroup$ The material set up is one principled volume node in either case, but I will go ahead and try. $\endgroup$
    – TheLabCat
    Mar 14 at 18:20
  • $\begingroup$ I think I might have it! I redid the effect, and I see that in the material, black body intensity is turned all the way up. I’m pretty sure it was zero before… $\endgroup$
    – TheLabCat
    Mar 14 at 18:31
0
$\begingroup$

After changing the emitter type from smoke to fire, in the domain material’s principled volume node, turn the black body intensity value all the way up to one.

$\endgroup$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.