2
$\begingroup$

A hair particle system is used to emit leaves from an animated tree, for some reason the leaves rotate. How can this be stopped? I know that I could convert the particles to meshes, but I would prefer too keep the particles.

Two subsequent frames:

enter image description here enter image description here

The settings:

enter image description here

Emit from faces instead of vertices makes it appear a bit more stable (but then no more particles will be emitted at the tips of the branches), not all leaves are rotating.

.blend

$\endgroup$
  • $\begingroup$ You have Newtonian Physics enabled for one thing. And velocity is set to 1. Does that change anything? $\endgroup$ – VRM Dec 29 '14 at 13:13
  • $\begingroup$ @NoviceInDisguise Setting physics to No or Velocity/Normal to 0.0 hides all leaves. $\endgroup$ – stacker Dec 29 '14 at 14:56
  • $\begingroup$ Interesting! I haven't run across this issue before, so I might need a .blend to experiment with. $\endgroup$ – VRM Dec 29 '14 at 15:14
  • $\begingroup$ @NoviceInDisguise Thanks, I added the .blend it took a while to get rid of 50mb textures.. $\endgroup$ – stacker Dec 29 '14 at 16:14
  • $\begingroup$ It only acts that way when the particle system comes after the armature in the modifier stack. So the armature deform modifier is somehow messing up the particles . . . I'll let you know if I find anything else. $\endgroup$ – VRM Dec 29 '14 at 16:52
2
$\begingroup$

This sudden odd orientation change appears to be caused by the Armature modifier on the tree. The particles seem to respond much differently when the vertex positions are moving (it could possibly be because it is changing the size of the faces).

One way to combat this would be to move the perticle systems up the modifier stack until they are before the Armature modifier.

So instead of this: enter image description here

You would instead end up with this: enter image description here

It is important to note that when the armature moves the mesh, the particles might not move with it. You will need to convert to a mesh and add it to the armature deformation.

$\endgroup$
  • $\begingroup$ Unfortunately the leaves are no longer animated when the modifier order is changed. I noticed this after several hours of rendering. $\endgroup$ – stacker Dec 31 '14 at 11:33
  • $\begingroup$ I'm sorry about that! I put it in the answer at the bottom when I first posted. $\endgroup$ – VRM Dec 31 '14 at 13:13
  • $\begingroup$ Oh sorry my bad, didn't read to the end I was already happy after your comment. $\endgroup$ – stacker Dec 31 '14 at 13:44
2
$\begingroup$

I found a way to keep the unconverted particle system by enabling rotation and setting the initial orientation to normal (The conversion to mesh brought some performance issues).

When rotation is unchecked again, the emitted leaves don't start to rotate again. It seems that Blender (v2.71) does some initialization here which is not done otherwise.

enter image description here

$\endgroup$
  • $\begingroup$ Very interesting! $\endgroup$ – VRM Jan 3 '15 at 2:31

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.