0
$\begingroup$

I use emissions to create flat renders, and I used this node layout in Eevee for images with alpha channels.

provided by another blender users

The above was provided to me by another user.

I've recently updated 2.91.2 and now I can no longer use this lay out. In the current image I'm using, I'm trying to render a checkerboard tile where the white spaces are transparent.

enter image description here

The original texture is png with alpha channel enter image description here

But when I apply the same node layout I get a weird interpretation that isn't even transparent.

enter image description here

It instead creates a weird grid like wireframe effect. Why is this? Did they change how this works or am I doing something visibly wrong.

EDIT: I also went back to an older file, and the effect still works, UNTIL I apply it to a new mesh. By that I mean, copy and paste. Same image, same nodes, no alpha channel. HOWEVER if I use material copy via CTRL+L it does work. I am completely at a loss

Cheers!

$\endgroup$
4
  • 1
    $\begingroup$ check when you press n in the material editor > options, if blend mode is set to alpha blend or alpha hashed. $\endgroup$
    – Alex bries
    Mar 13, 2021 at 21:05
  • $\begingroup$ I just looked at the image and your blend mode is set to opaque, which will render alpha to black. $\endgroup$
    – Alex bries
    Mar 13, 2021 at 21:06
  • $\begingroup$ Yeah I think that solved it. $\endgroup$ Mar 13, 2021 at 21:30
  • 1
    $\begingroup$ if you solved it, in order for people to find this answer when they search for it, answer your question and tag it as the correct answer. $\endgroup$
    – J Block
    Mar 14, 2021 at 9:58

1 Answer 1

0
$\begingroup$

Answer from a helpful person

"check when you press n in the material editor > options, if blend mode is set to alpha blend or alpha hashed. – Alex bries"

$\endgroup$

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .