I have problems baking a smoke simulation with Mantaflow, I tried Blender 2.92 and 2.93 Alpha. When baking a (not very complex) simulation, Blender always crashes at around 30% of a 250 frames simulation. First of all I don't know why, because the domain resolution is only at 128, I've got and AMD Ryzen 3 at 16 GB RAM, a GTX1660 with 6 GB and more than 400 GB free disk space.

First of all, I've learned from tutorials that 128 is not a very high resolution for a good fire simulation. Is there a chance to tweak some settings so that the bake won't crash?

And if not, is there a chance to continue baking after a crash? I've set the cache to Resumable and when I hit Esc to stop baking, save my file and restart Blender I can resume baking where it stopped. The problem is, there comes the time when it crashes and although all files that were baked up to this moment are stored in the cache directory, hitting Resume will start from the frame that was baked when I last saved the file, not as far as it baked until it crashed.

Even worse, if I didn't stop baking and saved my file inbetween, there is not even a Resume button, I can only hit Bake Data and it starts from frame 1.

How can I tell Blender to resume after the finished frames?

I know that's actually two questions, but if one part could be answered the other becomes obsolete.

  • 1
    $\begingroup$ Mind sharing the file? $\endgroup$ Apr 13, 2021 at 9:56
  • $\begingroup$ Actually it's not a specific file... it's every time I try to simulate anything with a higher resolution. Although 128 is not really high. I'll prepare a file which crashes and upload. And it's not only the specified computer, the same happens on my crappy laptop and my AMD Ryzen 7 octacore PC with a GTX 1060 as well... baking them on 2.83 LTS works fine (even on the laptop), but they changed some options in the newer version of Mantaflow which I would like to keep. $\endgroup$ Apr 13, 2021 at 11:32
  • $\begingroup$ I've added a file. $\endgroup$ Apr 13, 2021 at 11:55

2 Answers 2


After realizing that there's no problem if I use Uni Cache (what I usually avoid) instead of OpenVDB I've found an answer myself even for OpenVDB. I don't know why nobody else is experiencing these problems because I'm using the default settings but if so, here's the simple thing I did:

In Blender 2.90 and above the OpenVDB volume format comes with Advanced Settings. Here you can choose Compression Volumes "None", "Blosc" and "Zip". The default value is "Blosc".

After switching to "Zip", the baking works without any problems. "None" works, too. Only "Blosc" makes all my machines crash.

The difference to Blender 2.83 LTS (which doesn't crash) is, there are no Advanced Settings in that version, probably it uses "Zip" or no compression instead of "Blosc".

  • 2
    $\begingroup$ Hey :). Glad you solved it and thanks for sharing your solution. Perhaps this is a bug worth reporting? $\endgroup$ Apr 15, 2021 at 18:29
  • $\begingroup$ I thought of that, but although this is the default setting I didn't hear anybody else complaining about it yet.... $\endgroup$ Apr 15, 2021 at 18:47
  • 1
    $\begingroup$ @GordonBrinkmann You saved so much of my time. Thanks! $\endgroup$ Jan 28, 2023 at 16:05
  • 1
    $\begingroup$ I actually managed to get a 512 res bake completed!! Switched to resumable (for obvs reasons but didn't need it in the end) and switched to Uni Cache option. Baked completely on the first attempt. $\endgroup$
    – Jammer
    May 23, 2023 at 7:23
  • 1
    $\begingroup$ @Jammer Well, Uni Cache does not have that problem - that's what I'm saying in the first sentence of my answer. I usually just avoid it because the files are larger and Uni Cache is a specific Blender format, while OpenVDB is used by other software as well and the files are smaller. $\endgroup$ Aug 14, 2023 at 11:47

As far as i know mantaflow is running on cpu, I'm runing your blend on a laptop no problem. Keep in mind it creates a lot of cash files as well.

  • be sure to have enough disk space for the cache
  • be sure to not create superlong folder names (there is a limit on depth size in windows).
    This can happen as a result of long project names subfolders etc.
  • clean up blender cache, (blender can keep a fair amount of cache data on a disk)
  • run blender locally or use a renderfarm, not over file shares (thats slow).
  • $\begingroup$ I've done simulations for some years now and never had these problems. Your tips would be quite useful if I were generally low on resources. But I have loads of space, all cleaned up, no long folder names and always work locally. My problem is this also happens on three different machines. And it only happens with 2.92 and 2.93, with 2.83 it works without problems. $\endgroup$ Apr 14, 2021 at 18:17
  • $\begingroup$ Freshly downloaded latest 2.93 Alpha, left all at default. Scaled default cube a little larger, added a sphere. Cube becomes domain, everything default except for the resolution set to 128, setting it to "Bake All" and choosing a (short named) folder for the baked cache. The sphere becomes the flow object, everything default except setting it to Inflow. Started baking and left the PC. After a while, Blender is shut down and there's only 195 frames finished of 250. When I re-open it I can play the baked cache but not finish it. Data files are only ridiculous 195 MB and 409 GB free disk space. $\endgroup$ Apr 15, 2021 at 12:26

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .