1
$\begingroup$

I am trying to cut out a tiny section from object (the red one) using Boolean modifier but when I do that it shows the object as hollow behind the cut out. But when I do the same with let's say Cube added from the Blender menu the cut out is solid - why?

Solutions I found around here talks about using Solidify modifier but that does not solve that for me: it just make the walls thicker but not doing the object solid and does not even respect the cut out shape (it should be like elongated ball as seen below)!

Can anyone tell me how to tell Blender that the cut out section needs to be solid and not hollow?

CLICK HERE FOR TEST BLENDER FILE

enter image description here

I am somehow starting to think maybe it is something with how is the object - LEGO brick - made, tho it is a standard official LDRAW brick repository DAT file imported into Blender, so it should not be the case (or I think it should not be thinking that anyone who made that 3D object known what he/she is doing when it is official brick from LDRAW). So maybe someone willing could look into possible design problems of the brick itself? Just a quick thought tho for those experienced Blender users (not my case).

EDIT It turns out something unspecified was wrong with my Blender 2.90.1, once I downloaded and installed the newest version (v2.92.0) everything worked instantly as expected...but I will check the right answer anyway as ti basically correctly stated as of what to do to achieve the cut out itslef. :-)

$\endgroup$
4
  • $\begingroup$ Hi!! This might be caused by the faces being wrongly oriented. Can you check that the normals of the faces of your object point outward? This can be done using the overlay settings "face orientation" in object mode, or "normals" in edit mode $\endgroup$
    – elie520
    Mar 12 at 14:38
  • $\begingroup$ hi, all normals pointing outward (blue), it shows red in the cut out when I apply the Boolean on my object, but blue when applied on Blender Cube object $\endgroup$
    – qraqatit
    Mar 12 at 14:41
  • $\begingroup$ Could you please share your project (or at least the object implicated) on pasteall.org/blend $\endgroup$
    – elie520
    Mar 12 at 14:48
  • $\begingroup$ I added the link into my post $\endgroup$
    – qraqatit
    Mar 12 at 14:58
2
$\begingroup$

I think your problem was that you never actually applied the modifier before deleting your carving object. Otherwise, as you can see, after I deleted your modifiers to restart with a fresh one, I could achieve the desired effect. I hope this helped.enter image description here

EDIT:

Here's a .gif of the procedure:

  1. delete the pending modifiers
  2. create a UV sphere (scale it down and drag it around)
  3. create a new modifier
  4. apply it
  5. delete the sphere

enter image description here

$\endgroup$
10
  • $\begingroup$ that is strange cos I did apply that modifier with the same result = hollow cutout + how you explain that with the blender Cube it is solid straight away even without applying it? It would be great if you could actually share your project BEFORE you apply your modifier(s) so I could check myself cos from what you are writing I see I did exactly the same. Also, if you first deleted my modifiers/objects and apply your there is really nothing I can take from it as you are working with not the same environment as I have here..so really it would be of great help if you could share yours, please. $\endgroup$
    – qraqatit
    Mar 12 at 15:17
  • $\begingroup$ I edited my answer, and you'll find the project here before applying the modifier: pasteall.org/blend/ff1538eb04d74b25afed9cd991f35a27 $\endgroup$
    – elie520
    Mar 12 at 15:41
  • $\begingroup$ Something may not have checked: did you also check the good orientation of the faces of the carving object you used? $\endgroup$
    – elie520
    Mar 12 at 15:44
  • $\begingroup$ Now this is MEGA STRANGE: I downloaded your file, opened it in my Blender 2.90.1, applied the Boolean madifier on the 2x4 brick 3D file, deleted the sphere and...I STILL GOT HOLLOW BRICK! :-((( Isn't there anything in the Blender settings that needs to be checked out first or something? $\endgroup$
    – qraqatit
    Mar 12 at 15:45
  • 1
    $\begingroup$ SOLVED: when I downloaded the newest version of Blender all works as it should, but I set your answer as the correct one anyway as your description is actually telling it right how it should be done (although I knew how to do it and my problem was somewhere else) $\endgroup$
    – qraqatit
    Mar 12 at 16:32

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.