1
$\begingroup$

I am in shader editor(blender ver. 2.92) and I simply can not connect nodes between each other. These lines, which should connect those little dots in nodes do not appear and I do not know what to do. I've searched how to deal with this problem for a week and still...Maybe somebody here knows how can I fix that?

I just need to connect these yellow Color dots and I ve tried all sorts of combinations, which I ve found on the forum such as: ⎈ Ctrl⇧ ShiftLMB LMB and ⎈ Ctrlt. File below

enter image description here

$\endgroup$
6
  • $\begingroup$ have you tried doing a factory reset? File > defaults > Load factory settings $\endgroup$
    – Mobin
    Mar 11, 2021 at 11:31
  • $\begingroup$ What exactly are you doing to try connecting the nodes together? Please edit your question and add a little more visual information. Gifs are useful to add short visual information in these cases. Ctrl+T on the output node will add a new world setup if you have node wrangler installed anyway... $\endgroup$
    – Timaroberts
    Mar 11, 2021 at 12:55
  • $\begingroup$ @Mobin thanks for the advice, but didnt work out for me...guess because I am a newbie and settings are not guilty :D $\endgroup$ Mar 12, 2021 at 11:21
  • $\begingroup$ @Chris Added, hope it helps! $\endgroup$ Mar 12, 2021 at 11:33
  • 1
    $\begingroup$ @brockmann oh? thanks for help, hope i ll deal with it :) $\endgroup$ Mar 12, 2021 at 11:46

3 Answers 3

1
$\begingroup$

Just increase the distance between the nodes you want to connect a bit and try again.

$\endgroup$
1
$\begingroup$

I've had this same problem working in 3.0.

I had two windows with shading workspace open, specifically Nodes window.
If I closed one, connectivity and movability returned.

$\endgroup$
0
$\begingroup$

Note that ⎈ Ctrl⇧ ShiftLMB LMB and ⎈ CtrlT mentioned in the question are functions from the Node Wrangler Addon (shipped with Blender but disabled by default).

While they do create connections, it isn't their primary purposes:

  • ⎈ Ctrl⇧ ShiftLMB LMB : Connect an output of the selected node to the final output of the node tree (...) to preview its output in the viewport.
  • ⎈ CtrlT : Add a setup of a texture node, Texture Coordinate, and Mapping nodes to any shader node.

The basic way of connecting nodes that should always work is to click and drag a socket, and drop it to another node's socket:

enter image description here

If no noodle appears while doing this, it sounds like either a graphics issue due to your system, or a bug.

You can check if your system meets Blender's requirements on : Requirements — blender.org

To update your drivers, the rule of thumbs is to simply get the latest available. But if you are interested in Cycles GPU rendering, you might also need to get a specific "variant" of your manufacturer's drivers. Hence, you should probably look at GPU Rendering — Blender Manual

If you confirmed your hardware is within Blender's target and your graphics driver is up-to-date, yet still have issues, please report a bug using Blender's menu Help ► Report A Bug.

$\endgroup$

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .