0
$\begingroup$

I'm very new to blender and I'm trying to make a simple character with a 2d face. I was following along with this tutorial (https://youtu.be/YGjwOEMgDGw?t=60) but I can't get my image to look transparent.

The whole image is black with white outline around everything that's not transparent

This is what it looks like in the blender image editor. The transparency shows up in that view.

Image editor showing image has alpha

The starting Shader setup is also different from the tutorial (I don't know enough to know what all this means)

Showing different Shader set up

But when I make it like the tutorial it looks like this, still not transparent (it also looks like in the image editor if I set the alpha to none).

The images black is shiny and theres a wierd white box enter image description here

I have no idea what settings I might have wrong or what I'm doing wrong. I've been stuck for about 2 hours on this so any help would be appreciated. I used photoshop to make the image (just incase there is some setting I need to set there), and also here are the import settings for the image.

import settings the alpha is set to straight

Again any help is appreciated. Thanks :)

$\endgroup$
0
$\begingroup$

If you imported your image by first creating an image plane (Add > Image > Background), then you will want to click on the resulting plane object in Object Mode, and then look in the Object Data tab of the Properties Panel to find its Opacity slider.

enter image description here

If you created it as a Background Image, you will want to select your camera instead (this is easiest to do in the Outliner window), and then look in the same Object Data tab from the Properties Panel, which will now show the object data for the camera. This will expose you to a different opacity slider.

enter image description here

Hope this helps.

$\endgroup$
1
  • $\begingroup$ I'm trying to use the image plane, but the object data for that doesn't have the picture icon. it instead has a triangle with squares are each corner and no group of settings that look similar to the first picture. I also tried the background image and that one was transparent, but it still had a white outline. I want to use a image plane object and not a background image. is there something else I have to do? $\endgroup$ – Knot-Known Mar 11 at 3:18
0
$\begingroup$

Ok I found my own answer here. I wasn't asking the right question or at least wasn't asking it well. I was using Eevee instead of cycles. didn't even know those things were important.

$\endgroup$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.