2
$\begingroup$

I have my camera set up to render my object with a transparent background in PNG format. But when i enable transparency, I get nothing rendered other than an empty PNG.

These are my settings for blender render shown in the image attached (may need to open image in another tab to see it larger)enter image description here:

Also as a side note, is there such an option in cycles render, as I could never find the option to render with transparent background so had to resort to blender render.

$\endgroup$
  • $\begingroup$ I assume that you didn't link the Composit node in Node Editor, however, a blend file is very helpful here, to quickly target it. You can try to upload it here $\endgroup$ – Leon Cheung Dec 28 '14 at 2:08
  • $\begingroup$ @LeonCheung pasteall.org/blend/33575 here you go. Warning it won't have good performance on poor PC specs. $\endgroup$ – Dave Dec 28 '14 at 2:15
2
$\begingroup$

According to your file, the problem is you are trying to use Cycles material node as BI material node, which cannot happen.

enter image description here

Solution:

  1. Switch the Render engine from Blender Render to Cycles;
  2. If you want to render it in Blender Render (BI), you have to either toggle off the Use Node button, or create a new material node readable for BI.

I assume the first one is your better option, since it seems you sort of mis-switched the engine at some point (or the material node is appended from anywhere else).

$\endgroup$
  • $\begingroup$ So which is better quality between the two types of renders? $\endgroup$ – Dave Dec 28 '14 at 4:17
  • 1
    $\begingroup$ Cycles by far. Actually, I'm not allowed to voice my opinion (curses!) but Cycles generally has more solid and realistic images. $\endgroup$ – Scalia Dec 28 '14 at 4:23

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.