4
$\begingroup$

I have made a simple studio setup to showcase a toy car model. In Cycles I am getting an estimated render time of about 1 hour which is unusual for a scene this simple. Upon making tweaks I realised that hiding the studio backdrop from the render cuts my render time to 8 minutes.The backdrop is a simple beveled plane consisting of 36 quads. I have my max bouces relatively low as well as the indirect light clamping

Intended Cycles render as rendered in EEVEE

This is the shot I am trying to render in Cycles as rendered in EEVEE

Backdrop

This is the size of my backdrop

Render Settings

And here are my render settings, which seem pretty tame all things considered.

enter image description here

Nodes for the cove.

$\endgroup$
4
  • 1
    $\begingroup$ What is the node graph for the backdrop material? $\endgroup$ Mar 10, 2021 at 5:40
  • $\begingroup$ It's a simple principled BSDF with a transparent png of the road stripes on the color socket. very basic as I said. Also I tried a render after removing the material from the backdrop entirely and I'm still getting the same exact render time. $\endgroup$ Mar 10, 2021 at 5:59
  • $\begingroup$ Can you share the snapshot of the node setup of the background. I can help then. $\endgroup$ Mar 10, 2021 at 6:44
  • $\begingroup$ Sure, here it is imgur.com/a/FB6LyCp but as I mentioned I am getting the same render time with or without the material $\endgroup$ Mar 10, 2021 at 8:25

2 Answers 2

5
$\begingroup$

The render-time difference isn't too surprising, given that without the background most of the camera rays would simply miss all of the geometry and so those tiles to the side would render extremely quickly compared to the rest. Adding the background means that those camera rays hit a surface and Cycles then needs to determine Diffuse rays from the rest of the geometry to shade each point on the surface.

One potential solution would be to use the new(ish) Adaptive Sampling option. This way you can set a noise threshold and those tiles far from the "track" should render quicker than they otherwise would, while still having enough samples to avoid noise.

$\endgroup$
1
  • $\begingroup$ I have seen your answer and I will agree that your answer is more concrete and much more working than mine. I would say Prakhar should use your method. Nevertheless, your answer is pretty good and all 4 solutions are open to using. I am upvoting your answer. $\endgroup$ Mar 10, 2021 at 14:38
-1
$\begingroup$

I have seen your comments and I think it is a problem with the scale of the plane. Try scaling lower the plane from right to left. That might cause fewer bounces to happen everywhere. If it still doesn't work, try increasing your tile size, because I guess that is the only problem. I would recommend setting the tile size to the size of the resolution, for example, if your image resolution is 1920x1080, try setting the tile size to that. I have seen you are using GPU compute, so I would say go with what I said. If it still doesn't work, I will say as a final resort to switch from GPU to CPU by setting the settings to normal ie. change the tile size to as it was. If these 3 things don't work, please share your blend file so that I can solve it.

Aster17

$\endgroup$
5
  • $\begingroup$ I did think it might be a material issue, so I double-checked by rendering it with the backdrop material removed. I am still getting the same slow render time. $\endgroup$ Mar 10, 2021 at 8:28
  • $\begingroup$ Did you try my method ? $\endgroup$ Mar 10, 2021 at 8:32
  • $\begingroup$ Yes I did, to no avail.The render time is still abysmally slow. $\endgroup$ Mar 10, 2021 at 8:43
  • 1
    $\begingroup$ Tile size can be automatically determined using the auto tile size addon. $\endgroup$ Mar 10, 2021 at 16:33
  • $\begingroup$ @ Allen Simpson Thanks for the tip $\endgroup$ Mar 11, 2021 at 12:16

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .