2
$\begingroup$

https://photos.app.goo.gl/YvCDueDAgrZonAcE7

Hopefully you guys are able to see that link above. However, let me try to explain the issue:

I am trying to animate a basic cube. However, I only want to animate one face of the cube and leave the rest intact with the same location and scale.

I am able to insert the first keyframe (frame 0) but when I try insert the second keyframe (frame 60) it seems to "cancel the first keyframe and makes them both look the same, which obviously results in no animation.

Any idea how to keep the first frame the way it is when add the second keyframe?

PS.: shape keys are not possible here because in the actual video I would have multiple movements, so I would need many shape keys.

$\endgroup$
1
$\begingroup$

This kind of animation is - AFAIK - only possible with shape keys.

And as you can see - you can only add a keyframe to location (not to vertices or frame) and just in object mode. So the animation frame does relate to the whole object and it's location. Not to vertices or faces or edges.

$\endgroup$
3
  • $\begingroup$ "only possible with shape keys" - blender.stackexchange.com/questions/9355/… $\endgroup$ – Markus von Broady Mar 9 at 20:34
  • $\begingroup$ HI Chris, thanks for the reply. The problem in my case is that I would need 3 or 4 shape key values to make my actual animation work given how my character moves, and as far as I know we can only have 2 shape key values, no? $\endgroup$ – Ricafabreu2 Mar 9 at 20:39
  • $\begingroup$ you can have as many shape keys as you want - AFAIK - just the memory of your computer is your limit ;) $\endgroup$ – Chris Mar 9 at 20:41
0
$\begingroup$

To do exactly what you want, without shape keys, you will need to enable the AnimAll addon by going to User Preferences, then highlighting the Addon category, then typing "AnimAll" in the search field to make it pop up in the list, then checking the box beside its listing to enable the addon. Now you can keyframe vertices in Edit Mode in the same way that you would normally keyframe primitives in Object Mode. However, standard shortcut keys do not seem to create keyframes. You may find that you need to set them by clicking with the mouse in the included AnimAll UI, which can be expanded by clicking on its associated tab the Properties Shelf (press n to bring up the Shelf). The properties shelf tabs appear immeditaely to the right of your main 3D view, but still left of the Properties Panel. I also found that while the keyframes are SET in Edit Mode, their effects cannot be displayed until manually scrubbing the timeline in Object Mode.

$\endgroup$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.