I'm working on a cap for a little device, but whatever I do, I cannot seem to avoid self intersecting geometry from being generated.

I fiddled with the order of modifiers and solidify parameters, to no avail.

Internal geometry

blender file


1 Answer 1


First thing, move the Solidify mod above the Sub-D mod, then change the settings in the Solidify mod to "Edge Data -> Rim -> 1.0" And check your crease values, there are a few of them, especially around that corner, that are not 1.0, this will screw up the Edge Data.

enter image description here

This will fix most of the problem.

After that, there will be a small issue left that is caused by the edges near that corner being a smaller distance away from the corner than your solidify value (1mm) This means that when Blender tries to offset them, they overlap. Simply move them away a little to fix the corner. Use GG to slide them away.

(These verts)

enter image description here

Remember, Blender is not CAD! There are a whole different set of rules to learn and follow! :)

  • $\begingroup$ Swapping solidify and subsurf in the modifier stack and setting edge data->rim to one changes the model in quite a number of ways: the round hole becomes hexagonal, and the rounded edges end in sharp corners at the bottom of the model, which is not what I have in mind... $\endgroup$
    – eezacque
    Mar 8, 2021 at 12:13
  • $\begingroup$ So it does, but it did fix the issue you wrote the question about. You will need to apply the Solidify mod and deal with the crease edges around your other geo. Sometimes, we just need to apply our mods, they are not always the best way of modeling. Your model as a whole is not a good way to model it. I came from 20 years of professional CAD before I started Blender, and I had to over come the problems, mindset and realizations you are facing now. :) It does get easier mate! Stick with it! :) $\endgroup$
    – Psyonic
    Mar 9, 2021 at 8:53

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .