0
$\begingroup$

This seems to be a pretty typical problem. But reading many threads did not yet help me to find a solution.

I want to model a supposedly simple object. Unfortunately, the attached image is magnified. I have no idea how to make the image smaller. Looking at a smaller image makes it easier to understand the form.

I first tried to subdivide a base cube and model the cutouts, but this was not very successful.

The closest I came was using a boolean. However, I am not able to bevel the borders of the cutouts, regardless of the order of the booleans. When applying the boolean the geometry does not look too bad, but I still can't bevel the borders of the cutout, neither using a modifier nor directly.

I attach two .blend files: one with the boolean present, and one with the boolean applied. The design sketches can be found as empties in the .blend file.

Edit: @Chris. Your proposal did not help. This was my first idea as well. But if you look at the resulting topology after applying the boolean does not look too bad. I added another screenshot.

Topology after applying the boolean

StopTablet

.blend files

$\endgroup$
2
1
$\begingroup$

I opened the first of the attached files, StopTablet2.blend... the Bevel Modifier was before the Boolean Modifier so I changed that. And voilà, the object was beveled. And even more after disabling Clamp Overlap.

In the second file StopTablet3.blend you've set Limit Method of the Bevel Modifier to Weight, but only the edges on the top have bevel weights assigned (you can see it by the blue color). If you give a bevel weight to the other edges you want to bevel it works, at least if you disable Clamp Overlap again. Or use a different Limit Method like you did in the other file.

bevel weight

$\endgroup$
3
  • $\begingroup$ I had tried that before. That is the reason, why the other edges were still marked. But this leads to shading issues, especially at the corners. Any idea, how to get rid of these? Here is an updated .blend file: dropbox.com/t/CydVzOCWlBUA3J80 $\endgroup$ – Chris S. Mar 7 at 16:28
  • $\begingroup$ The shading issues are usually caused by overlapping faces etc. The problem with your edges is, if you set the bevel width so high that the bevel will move over the next edge it results in bad geometry and shading issues. The Clamp Overlap feature is there to prevent that, but this can lead to non-beveld edges in some parts. Since you are using Weight as Limit Method, you can try to give problematic edges a lower Bevel Weight like 0.5 instead of 1. Or you have to remove edges which are in danger to be overlapped by hitting X > Dissolve Edges. $\endgroup$ – Gordon Brinkmann Mar 7 at 16:40
  • 1
    $\begingroup$ And taking a closer look at your mesh I see that the geometry is worse than it seems at first glance. There are some overlapping or very close vertices. Maybe you should select all, then hit M > Merge By Distance > 0.0001 (not larger, because then you ruin your mesh). This deletes 12 vertices that caused problems. Oh and setting the curved edges to a bevel weight of 0.6 should be fine. $\endgroup$ – Gordon Brinkmann Mar 7 at 16:56

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.