1
$\begingroup$

So I made windows for my building in an Eevee scene, but at certain angles, it doesn't show what is on the other side and instead shows a reflection of what's below my building. I am using the Principled BSDF, with Transmission at 100%, Roughness at 0, Metalic at 0, and everything else at their default values. IOR is 1.45. Any tips on how to get my shader to just allow me to see through at any angle while still looking like glass? Thanks in advance for the help!

Edit: I also have refractions and reflections enabled in both my eevee render settings and the shader settings

Correct

enter image description here

$\endgroup$
2
  • $\begingroup$ Is your glass made up of just a single surface or does it have ‘thickness’. Try adding a Solidify modifier and see if that helps. $\endgroup$ Mar 4 '21 at 23:06
  • $\begingroup$ @RichSedman It is a mesh with thickness, a cube I scaled down. Should I try a plane instead? $\endgroup$
    – Blith
    Mar 5 '21 at 19:26
2
$\begingroup$

So I found that adjusting "Refraction Depth" In the settings of the shader from 0 to .1, and the problem disappeared.

enter image description here

$\endgroup$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.