enter image description hereenter image description here

enter image description hereenter image description here enter image description here

enter image description here

That's the final result i'd like to achieve but more round

Sorry, i'm starting with blender...

  • 4
    $\begingroup$ The geometry in the third picture is not a cylinder, it’s an ellipsoid with rounded edges. Can you post a picture of what you want it to look like in the end? $\endgroup$
    – TheLabCat
    Mar 4, 2021 at 0:05
  • $\begingroup$ sure, i am really having trouble with it $\endgroup$
    – Miki
    Mar 11, 2021 at 12:35

1 Answer 1


The following two methods might help to fix your problem:

Method 1

Scale down a cylinder to be the size of your current mesh. After that go in Edit Mode, select all of your mesh by pressing A, and then Subdivide. Set the number of cuts to three. Once that is done, add a Subdivision Surface Modifier and set it to 2 or 3 (Don't forget to add Loop Cuts on the top and bottom of the mesh by hitting Ctrl+R and then dragging. Otherwise you will get a very round mesh) If you are in cycles you can set the feature set to experimental and enable adaptive subdivision in the Subdivision Surface modifier and then in the material properties go to Settings and then set bump only to displacement and bump to save render times.

Then give that cylinder the same material you gave to your current mesh.

Method 2

If you want your current mesh to have the material, then your problem is that your UV's are stretched. Make sure you have given seams on the right places. To make sure there is no stretch, go to the UV Editing Workspace and in Edit Mode select your entire mesh. Then on the side panel on the left, go to Overlays and press display stretch (The colours any other than almost dark blue like cyan or green mean there is stretch).

enter image description here

If there is any stretching, you will have to first go to Object Mode and then press Ctrl+A and click Apply Scale. Come back to Edit Mode, then select your entire mesh and press U > Unwrap. If the stretching is still visible you would have to add more seams at the right place and then hit U > Unwrap again.

  • $\begingroup$ I don't think that subdividing the mesh even further and also adding a subdivision modifier on top of that, is a helpful recommendation...? Why do you think this shape needs billions of polygons? More than 3 subdivision levels is overkill in most cases. $\endgroup$
    – brockmann
    Mar 4, 2021 at 12:47
  • $\begingroup$ @brockmann I thought of this but I still wrote this so there won't be lack of detail for the displacement to work properly on the mesh. I'll edit the answer to be one step lower in te subdiv modifier. And I also did it because I asked to add a cylinder which is normally very low-poly. $\endgroup$ Mar 4, 2021 at 12:58
  • $\begingroup$ For displacement, enable 'Adaptive': docs.blender.org/manual/en/latest/render/cycles/object_settings/… and blender.stackexchange.com/questions/123914/… $\endgroup$
    – brockmann
    Mar 4, 2021 at 13:04
  • $\begingroup$ @brockmann Oh yes I forgot about adaptive subdivision. $\endgroup$ Mar 4, 2021 at 13:06
  • $\begingroup$ Hey, so i checked the UV map and it is an absolute mess. I did everything you said but i don't know where to create the seams. How could i fix this? $\endgroup$
    – Miki
    Mar 11, 2021 at 12:33

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .