1
$\begingroup$

I'm having an issue where it shows that the background of the render is transparent, though it turns black when I save it as a png file.

In the modelling state and in the render state:

After I save it as a png:

enter image description here

As you can see it turn's black and I'm not too sure why...

$\endgroup$
1
  • 2
    $\begingroup$ Did you save the PNG file in RGBA format? "A" is the alpha channel used for transparency and you may have saved it without in RGB format. $\endgroup$
    – Blunder
    Commented Mar 3, 2021 at 14:06

6 Answers 6

2
$\begingroup$

I just had the same problem and I check that all the settings were correct (RGBA selected and transparent film also). The problem was happening because I was doing some compositing, which might be your case. In the render tab, top right corner there is a Composite box, change that into View Layer and it should work fine!

$\endgroup$
2
$\begingroup$

After rendering go to Image > Save as click on File Format field select PNG, set color to RGBA, then Save as image.

$\endgroup$
2
$\begingroup$

I had the same issue. Before the png's I rendered out an animation where I used in the image output tab FFmpeg. Because then it "overrides" the render image format when you click it and you have to make sure you have that in png. and RGBA

png - RGBA

$\endgroup$
1
$\begingroup$

i had same issue - RGBA was ticked though still same issue occured with black background

i managed to fix it by going into: Render properties, choosing the "FILM" Tab and ticking the TRANSPARENT box

hope it helps, took me ages lol

enter image description here

$\endgroup$
1
$\begingroup$

Another cause of this problem is if your alpha is disabled in the compositor editor. Screenshot of the compositing window

$\endgroup$
1
$\begingroup$

In my Case it was in Compositing the "Lens Distortion" node. I dont know why, it cant render in alpha with it.

$\endgroup$
1
  • 1
    $\begingroup$ Thank you Advanced-Nooby. Everyone's advice on this forum really helped me, but my issue specifically was the lens distortion node causing a black background. removing it helped me fix the issue $\endgroup$
    – BiSh
    Commented Feb 14, 2023 at 17:32

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .