1
$\begingroup$

I'm new on this site. My problem is with a glass window. The top portion of the window is opaque (see Render) The glass is a standard setup (Glass BSDF+Transparent BDSF to Mix Shader to Material Output). There's a light (sun) aimed at an angle directed at the window and a plane with an emission node on the ceiling. I'm using Blender 2.91.2 Render engine: Cycles GPU Compute: CUDA OpenImageDenoise See images for some of my settings.Render Settings Material settings Let me know if you've seen or had this problem before. Thanks in advance!

Updated render with the sun perpendicular to the window: Render_2

Updated render using an area light: Swapped Emission plane for Area light

$\endgroup$
8
  • $\begingroup$ Isnt that because you have an object in the scene that is in Outliner hidden from viewport but not from rendering? $\endgroup$ – vklidu Mar 3 at 13:37
  • $\begingroup$ Good question vklidu, I checked and there's nothing there, I moved the sun down to shine directly into the window to check. Maybe it's a weird reflection? I'll try and update the question with the new render to show you. $\endgroup$ – jmodeller Mar 3 at 16:27
  • $\begingroup$ Even with direct direction it is visible on top. Your result looks weird to me, because I would expect upper part to be a glass or transparent, but it's dark blured with edge. In general you should specify the factor of mixing these two shaders. Why don't use only Glass shader? The only one think that comes to my mind ... Does your glass has a Thickness or is it just a single face? Also turn off denoiser that probably generates illusion of issue at the moment. Or quicker share blend with just the window if issue still there. $\endgroup$ – vklidu Mar 4 at 8:29
  • $\begingroup$ Thanks again for the suggestions vklidu. I checked the window construction and I'd made it double glazed. I deleted one of the glass panels and that seemed to work. But then I re-activated the light and the problem came back so maybe it's something to do with that light. I'm trying to troubleshoot the the problem a bit more now. I was going to share the blend file but even after deleting almost everything and purging it's still quite large. $\endgroup$ – jmodeller Mar 4 at 16:54
  • $\begingroup$ Append glass, wall and light into a new file, it can't be a big file. $\endgroup$ – vklidu Mar 4 at 21:36
0
$\begingroup$

I would say it is just coincidence. The upper part is shadow casted by outside wall. It looks solid for several reasons. Partly because rendering this glass is very noise and thanks to denoising it just looks like flat (even more with your contrasted image).

enter image description here

When rendering in viewport without denoising, it looks also solid but with some more details.

enter image description here

As you already discovered - two "Table Lights" do some difference in render, even they are far and with very low power (just 10W and 60 W). Here rendered without those lights.

enter image description here

With those lights the render is significantly darker ... that is weird and I don't have an explanation for that, just theory.

Left render with two Point lights / Right render without ... enter image description here

With provided file I didn't get such solid thing for final render with 240 samples.

Left render with two Point lights / Right render without ... enter image description here

There is a difference in light rays bouncing, so it can be possibly caused by Render Properties > Light Paths > Clamping > Indirect Light. Also you are using Limited GL preset so try to increase Max Bounce for Diffuse to 8. With those changes the render seems to be same brightness also with the two Point Lights.

enter image description here

$\endgroup$
3
  • $\begingroup$ Thanks vklidu, that removed that weird opaque part at the top of the window, but now there are no direct light rays entering and hitting the porcelain like before. Is there any way to have both? In fact I disabled the light in the bathroom and there is no light entering from outside now. $\endgroup$ – jmodeller Mar 3 at 17:35
  • $\begingroup$ Edited ... still not sure if I bring some light into it :) $\endgroup$ – vklidu Mar 6 at 22:48
  • $\begingroup$ Great work vklidu! Lighting is always a very tricky part of the rendering process for me. I really appreciate your in depth explanation. I'll try adjusting those light bounce and clamping settings you mentioned. $\endgroup$ – jmodeller Mar 7 at 13:57

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.