I've read other issues that look similar but this doesn't seem to be what I'm experiencing.

I'm making a conveyor belt type thing. The conveyor belt is a long array of blocks (array modifier was applied) that has a curve modifier. I'm animating the x position of the blocks which turns the conveyor belt around.

The conveyor belt object is a rigid body that is passive / animated true / shape: mesh / source: deform (I tried final and it doesn't make a difference). Deforming is checked.

I have a bunch of rigid body boxes that are set to active. The boxes rest on top of the conveyor belt as if it wasn't modified with the curve.

Any thoughts?

enter image description here

  • $\begingroup$ This is just a guess, based on not much experience with this in the past, but I have always been of the impression that passive rigid bodies in Blender won't work right unless they remain completely stationary. In my current test, one block (active rigid) falls upon another block (passive rigid). It worked fine with a stationary passive. But then I decided to set keyframes on the passive rigid to make it move into striking position just in time to be landed on. The active rigid went right through it. I wonder if some similar issue is at work in your case. $\endgroup$ – R-800 Mar 3 at 5:56
  • $\begingroup$ As I think on this more, I want to ask if you have looked into the possibility of using rigid body constraints, because I get the impression that this is a possible use case for them. Though I'm not certain. $\endgroup$ – R-800 Mar 3 at 6:00
  • $\begingroup$ Hi R-800. This is not the case. There are plenty of examples online that show passive animated rigid body elements interacting with dynamic rigid body elements. For example: youtu.be/bpXLVvEzv_w?t=587. In fact, my boxes are sitting on the animated element and animate with it just fine. The problem is that they don't sit on the deformed curve but rather it's as if they're sitting on the element without the modifier. There is supposedly an option to rectify this which is to select that the mesh is deforming, which I have. But it doesn't fix the issue. $\endgroup$ – Donald Richardson Mar 3 at 14:05
  • $\begingroup$ This is a workaround that should work in 2.9 - this sort of thing, only slower. - 1drv.ms/u/s!AtkhCKZLZs_Pg2FXreH06NvX-O3t?e=m0CYGj $\endgroup$ – Edgel3D Mar 5 at 2:07

This is a bug with Blender 2.9. Works fine in Blender 2.8.


Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.