0
$\begingroup$

This is how my imported stl looks inside the view port in Blender 2.92:

enter image description here

When I view it through the camera it looks like this:

enter image description here

The object seems to be transparent which is not what I want. Any suggestions on how I can make it look like in the view port?

Edit:

Please note that I want to create a svg from the front view of the object. This is why I set the camera far away from the object and increased the focal length, to obtain straight object lines:

enter image description here

enter image description here

It seems to help when I switch from perspective to orthographic:

enter image description here

I am still not sure which camera settings I should choos for my use case (create svg in Blender's Freestyle addon). I thought of having a tele camera and therefore choose the perspective view with a high focal length. Which settings do you suggest?

$\endgroup$
1
$\begingroup$

This is just because you are viewing it from the front. Move the camera a bit in any direction, and it should look better. You could also give the text a different color in rendering. It isn't transparent, just hard to see

$\endgroup$
5
  • $\begingroup$ Thank you for your help, I need to have the camera look straight at the object because I want to use Freestyle to obtain a svg. I should have added, that I am not really concerned about the text. What bugs me are the openings (especially the right hole) which seem to shine through the object. $\endgroup$
    – evolved
    Mar 2 '21 at 22:01
  • $\begingroup$ Go to your camera properties and turn the clip start down to get rid of the hole. If you need more elaborate instructions let me know. $\endgroup$
    – Relevred
    Mar 2 '21 at 22:10
  • $\begingroup$ Thank you this was also one issue I initially had. I have added more images showing the settings. And I think using the orthographic view seems to help in my case. But I though using a perspective camera with high focal length would suite my needs. $\endgroup$
    – evolved
    Mar 2 '21 at 22:11
  • $\begingroup$ Do you know why the perspective camera creates a transparent object? $\endgroup$
    – evolved
    Mar 2 '21 at 22:12
  • $\begingroup$ If you want to look at the inside an object, you just get close to it until you pass though the mesh. This is why it clips though. Though it may not seem like it, your object is too close to your camera, and your camera is clipping though it. However, in orthographic, you cant look inside an object, which is why the problem is removed. Reducing the clip start means that you have to get closer to the object to see through it. The fact that orthographic fixes it is just because of the rule that you can't look inside objects while in that mode. It isn't the best solution, but it works. $\endgroup$
    – Relevred
    Mar 3 '21 at 2:23

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.