0
$\begingroup$

New blender user here, I'm trying to fade-in an image in a 3D Animation in blender 2.9. I was able to import an image as a plane.

Looked on youtube and there were some tutorial about transparency or visibility, but I wasn't able to replicate any of those because the interface is different. I also can't find any options where I can set or animate the transparency/visibility.

I also tried this: Fade in action applicable to all objects (in cycles) but I kinda failed in the first steps into nodes stuff.

When I pasted the image in Blender with drag and drop I was able to set the visibility, but the image doesnt appear in the final render.

Here is stated why: Imported image is not showing in render

It's just a reference.

Is there an option I'm missing in the material properties tab or any other tab? Or do I have to do this with Nodes? If so I am ready to learn more about it. Or is there another option to fade-in an image in an animation in blender 2.9?

Or I could try to animate it with blender 2.8 instead of 2.9? (Can I open my 2.9 blender file with blender 2.8?)

$\endgroup$
1
$\begingroup$

(NOTE: You need to have the "Import images to planes" addon enabled to do this).

Step 1 (Import the image):

enter image description here

Step 2 (Open the shader editor): enter image description here

Step 3 (Add a mix shader in between the principled shader and the material output (Change the factor to 0), then add a transparent shader to the bottom shader input): enter image description here

Step 4 (Go to the frame you want the image to start fading out (For me it's frame 1)):

enter image description here

Step 5 (Add a keyframe to the factor):

enter image description here

Step 6 (Go to the frame you want the image to fully fade out, and change the factor value to 1):

enter image description here

Step 7 (Add a keyframe to the factor of 1):

enter image description here

And you're done! When you render it, it should look like this: enter image description here

(Sorry for the image, it was the last thing in my downloads folder).

$\endgroup$
3
  • 1
    $\begingroup$ If its not showing in renders, make sure "Renders" is enabled in the object propertys. $\endgroup$ – Daniel Mar 2 at 20:47
  • $\begingroup$ Also go to the materials tab > settings > Blend mode > Alpha blend. This is make it transparent. If you don't do this it may not work. Its also worth mentioning that the method daniel gave (which is completely correct) method works with anything, not just images $\endgroup$ – Relevred Mar 2 at 20:56
  • $\begingroup$ That is exactly what I wanted to be able to do. THANK You very much. $\endgroup$ – theliadir Mar 3 at 11:00

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.