0
$\begingroup$

I have a very simple setup in my compositor: Simply an image and a mask:

Compositor pipeline

I want to mask out parts of the image that it is fully transparent except for parts of the image. The final image should look like this (simplified setup, later I want to use the image as overlay):

viewer

This is actually the look of the viewer node. As you can see, the compositor is connected the same way, but the final image looks like this (actually, everything in the : final image in preview window

Apparently, the mask is applied, but somehow a semi transparent image is also applied.

I disabled background in camera (I actually deleted the camera and tried it). I disabled "Use for rendering" in view layer. I disabled the sequencer in output properties.

I actually thought this is not working, but it only seems to fail when looking at the render output in blender, the actual file is correct. Is this a bug or do I miss the option for this somewhere?

$\endgroup$
2
  • $\begingroup$ please provide your blend file $\endgroup$
    – Chris
    Mar 2 at 12:39
  • $\begingroup$ Hello :). You can share your file here: pasteall.org/blend $\endgroup$ Mar 2 at 13:25
1
$\begingroup$

It appears you are using blender 2.8. In blender 2.92, the set alpha node is updated to allow apply mask mode. To fix this, drop an alpha convert node after the set alpha node. Make sure it is set to convert straight to premul. That should fix your alpha problem.

$\endgroup$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.