0
$\begingroup$

[![enter image description here][1]][1]Switching from Eevee to Cycles rendering turns the textures seen in Eevee and Material Preview black in the cycles rendering screen. Is there anyway to make the texture show up in Cycles Rendering the same way it shows up in Eevee Rendering? The model in question is a ported model from the Steam Workshop, the model uses qc format and the textures use tga format, sRGB color space. Below are picture examples of what I see starting from my Eevee View, to Cycles View, and an example of my shader nodes that places the texture into the model.

View from Eevee Rendering

View from Cycles Rendering

An example of one of my nodes that implements the texture into the model

UPDATE

After following @Gorgious advice on using a normal map node, I manage to make the model not be completely black but instead have some interaction with the lights around it. See picture 1.

On the other hand, before that, I disabled the alpha node of the main texture picture being linked into the specular option of the principle BSDF. See Picture 2.

The reason I link the two in the first place is because if its not linked together, for somereason the texture does not have its details. See picture 3 and compare it with Picture two. Is there anyway to subvert this? Thank you for the wonderful advice and feedback you have given me, it has given me alot of insight and knowledge on the ins and outs of my workflow more than I have myself.

Picture number 4 is what I still see after using the advice @Gorgious and with the same node settings as with Picture number 3 but on render mode.

Picture 1 Picture 2 Picture 3

$\endgroup$
8
  • $\begingroup$ Consider uploading your file to the blend exchange so we can help you faster. blend-exchange.com $\endgroup$ Mar 2 at 4:43
  • $\begingroup$ <img src="https://blend-exchange.com/embedImage.png?bid=4VE67J8Z" /> sorry about that $\endgroup$
    – louie
    Mar 2 at 5:58
  • $\begingroup$ How interesting, so the reason why it's going completely black is due to your bump maps. I can't seem to figure out what's causing that strange line to move across the entire model though. Will keep investigating. $\endgroup$ Mar 2 at 8:09
  • $\begingroup$ Yeah, it's definitely the bump maps. Muting them with node wrangler stops it from happening. $\endgroup$ Mar 2 at 8:12
  • $\begingroup$ huh, how strange, ill look into it myself and see if I can make it so that it stops its effects or completely not use bump maps at all. Thank you for the heads up! $\endgroup$
    – louie
    Mar 2 at 10:22

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.