3
$\begingroup$

I have a stripped-down scene with a lamp and a tv screen, each having an Emission shader, I am using Cycles renderer, Blender 2.92, Windows 10.

UPDATE 2: After making several changes to reflect the suggestions form Rich and Martynas it looks better now IMO. (Far from perfect, I admit.) While the scene is now significantly dimmer the light output is more realistic IMO, for such a small lamp and supposedly OLED, and mostly black, screen:
enter image description here
(There is now only a hint of purple tint on the couch from the screen, as it should be. Also the lamp is burning phosphorus no more.)
All changes made are listed in the comment under Martynas' answer.

UPDATE: After sleeping on it, now I think the Clamp of Indirect Light is the key, and I should instead fix the artifacts. (See section "What I tried.")

The file

The issue

When the tv screen is not in scene the lamp shines as expected... enter image description here

...when I add the tv the whole scene actually seems dimmer. (See the shadow on the lamp base.) enter image description here

The shaders

the bulb shader:
enter image description here
(Yes, I went with 10000; started with 1, 100, 500, but all seemed too dim.)

the screen shader:
enter image description here

Render settings

enter image description here enter image description here

What I tried

I tried to play around with Clamp for Indirect light, changing it from 15 to 0. The scene actually got brighter, even too bright, but I was getting strange artifacts. (I tried to fight those by changing the Denoiser settings, but achieved nothing.) enter image description here

Rendering the scene with CPU only.

Tossing out the Light Path + Mix shader from the screen material. (The hypothesis being that maybe this affects rays emitted by the bulb material.)

$\endgroup$
11
  • 1
    $\begingroup$ Just realized the Mix shader together with the Light Path on the scrub could be the culprit. Maybe they are lowering the energy of the rays emitted from the bulb. $\endgroup$ – Jaroslav Záruba Mar 2 at 2:55
  • $\begingroup$ Have you tried rendering a test render with CPU? It could possibly be an issue with GPU - eg, the extra complexity of your scene meaning you run out of resources such as memory. $\endgroup$ – Rich Sedman Mar 2 at 7:42
  • $\begingroup$ By "scrub" I meant screen, thanks auto-correct! :) @RichSedman I have just tested it also with CPU only, no change there. $\endgroup$ – Jaroslav Záruba Mar 2 at 8:35
  • 1
    $\begingroup$ You shouldn't need to clamp for something that should be so simple. Have you tried just turning the Emission shaders on the screen to zero so that they aren't emitting any light? How about replacing the full material with a 'default' grey diffuse? Remove each element one at a time and see where the problem stops occurring. Adding light to a scene should never make things darker (unless they are only appearing darker due to, say, some auto-exposure settings). $\endgroup$ – Rich Sedman Mar 2 at 9:06
  • 1
    $\begingroup$ I think the problem may be with your lamp. The bulb is hidden by the shade and therefor the only light that is escaping into your scene is that diffused or reflecting off the space below the lamp. When the emitter is present the screen is flooding out the light since it’s in direct line of sight. Try adding some emission to the shade itself (not physically accurate but gives the effect of light shining through and gives the renderer a chance of finding a path to a light source). $\endgroup$ – Rich Sedman Mar 2 at 10:11
3
$\begingroup$

Clamping stops light from being brighter. So if you need a light with strength of 10000 and clamp it at 15, you lose most of its effect. Turn off clamping at first, set up lights for the scene and only then check the values in your render by right clicking and dragging on the render result(maybe render a small test area) to adjust your values for the clamping when fireflies become a problem. You should use higher values than the brightest fireflies in your render. The "strange artifacts" have replaced the "strange noise" in previous versions without denoising and simply means you do not have enough samples. Increase the amount of samples. You could also add bigger light sources to your scene to avoid noise/denoising artifacts. It might also make sense to have more max light bounces in an interior scene.

$\endgroup$
1
  • 1
    $\begingroup$ In the end I went with a combination of advices from both you and @RichSedman: Clamp for Indirect Light to 0, Samples to 3072, total bounces to 24. Then I adjusted the material of the lamp shade (made it more transparent) which made it possible to reduce the Emission strength of the bulb from 10000 to 500. (Probably more realistic for such a small lamp and a large room.) I also reduced Emission strength of the screen from 35 to 3. (It is supposed to be OLED anyways, hence a mostly black screen could hardly turn the couch completely purple.) $\endgroup$ – Jaroslav Záruba Mar 2 at 16:30

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.