0
$\begingroup$

turning to you with a really strange issue - Blender only applies part of my texture onto a plane! I have an image texture that ranges from RGB black [0,0,0] to green [0,1,0] and red [1,0,0]. When I apply this texture onto a plane, without any shading, i.e., just the image texture node into material output, Blender only puts a part (roughly 80%) of the texture onto the plane (namely the part until green [0, 0.8, 0] and red [0.8, 0, 0]). This can be verified in UV Editor mode, when using the color picker tool and picking from the image texture and the texture plane, respectively: the image texture will give you [1.0, 1.0, 0.0] in the upper right corner, whereas the textured plane will return [0.8, 0.8, 0.0].

My problem is that I need the entire texture on the plane. I already tried experimenting with plane size, etc., but didn't have any success. Does anybody know what's going on here? This seems really strange. I attached the blend file and the texture!

Attached blend file:

$\endgroup$
3
  • $\begingroup$ I opened your file and everything is ok, whole texture visible. $\endgroup$ – Fowl Mar 1 at 10:30
  • $\begingroup$ Thanks! Did you check the color values at the upper right corner in the viewport? What RGB value does it return? $\endgroup$ – i2n Mar 1 at 10:34
  • $\begingroup$ In addition to Fowl's answer, change the Colorspace settings from Filmic to Standard to see the real colors in material view; see this. $\endgroup$ – scurest Mar 3 at 7:57
2
$\begingroup$

I think your problem is in view port settings.

As you wrote, your image RGB goes over variety of colors and the corners should give absolute number of the color (as 1.1.0 in case of yellow) This can be picked by color picker in UV editor or texture paint as the texture is shown without any view port shading.

In fact, the view port has some basic shading and light from the very beginning and the colors in 3D view port are always distorted by the environment as the pure color is not reachable in a real world normally.

There is no problem with the texture. If you want the absolute color output you have to set up you render, color or material to give you this output.

If you want it to be seen just in view port then change your shading.

enter image description here

enter image description here

$\endgroup$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.