1
$\begingroup$

Exercising facial expression animation with settlers rig... ...and having a problem with keeping the eyebrow bones on the face surface.

The rig and mesh are from Blender Cloud, Settlers. (see links below)

Transforming the L or R eyebrow controller deforms the mesh freely so it can penetrate the head mesh or depart from it.

My question is how can I attach it to the surface, so transformations are constrained to keep it above and on the head surface?

I tried to lock the y transformation, I added a limit distance constraint (target=head, clamp=surface)- both had no effect.

Any input would be greatly appreciated.

Links: The uploaded file:

The rig and mesh are from Blender Cloud, Settlers Gabby Settlers Blender Cloud Link

$\endgroup$
3
  • $\begingroup$ Could you share your file? It's hard to know what the problem is without it. $\endgroup$
    – R-800
    Feb 28 at 23:20
  • $\begingroup$ @R-800 Attached, sorry for the bother. I had to post the question before I could upload the file... and waited, it took some time to process. $\endgroup$
    – donbonbon
    Mar 1 at 0:12
  • $\begingroup$ When I use this rig, it behaves exactly the way you seem to be describing as the way you WANT it to behave. When I grab the cube shaped eyebrow controller, the eyebrow rig remains constrained to the head surface. It never departs from the face. Now, if I grab the eyebrow bones directly, those can pulled away from the face. But not if you use the controller. So I don't know what your issue is at this point. $\endgroup$
    – R-800
    Mar 1 at 1:27
1
$\begingroup$

That's easy! All you have to do is add a "Shrinkwrap" constraint to each bone and set the target to the mesh with the head. It'll stick to the surface. One of my favorite modifiers

$\endgroup$
1
  • $\begingroup$ It did the job. Thanks. Though, the Master bone was Target Normal Project and the other Near Vertex. When I tried to copy the Master setting (already set by Blender.org) it deformed strangely the eyebrow mesh. $\endgroup$
    – donbonbon
    Mar 1 at 9:05

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.