1
$\begingroup$

I tried a few threads already on Blender Stack Exchange:

How to render a background image in 2.8?

How to render a background image correctly?

why the background image I add not show in render?

I'm using 'Images as Background' add-on. I've tried the 'Film' 'Transparent' recommendation. The render icon is on in the outliner. I've messed with the nodes all day. Nothing seems to be working.

I made an animation in 2.79, and I opened the file in 2.83,(I checked the box to not load the UI thing) so maybe a few bugs from the old one got into the this file because I tried loading up a new 2.83 file and the background rendered just fine with no modifications.

I am using HitFilm 3 Express as my video editing program, I am more comfortable with it than Blender's internal video editing software. So I'm rendering out a greenscreen for the program to use.

enter image description here enter image description here enter image description here

$\endgroup$
3
  • $\begingroup$ Why this green backdrop? Suggest render your object (foreground) with transparent background enabled. $\endgroup$
    – brockmann
    Feb 28 at 20:34
  • $\begingroup$ That would be another option, yes. This option was linked to having a background image actually render with another project of mine, however transparency would be better. $\endgroup$
    – JaredWolf
    Feb 28 at 20:46
  • $\begingroup$ That's the only option for a nice comp, ideally rendered to openexr: blender.stackexchange.com/questions/106670/… $\endgroup$
    – brockmann
    Feb 28 at 20:50
1
$\begingroup$

So immediately after writing this post, I had a realization. Sometimes objects don't show up in the 3D viewer, so you increase the distance you can see by hitting 'N' and going to 'View'. However I can already see it in the 3D Viewer, but then I thought that there were different properties set to the camera than the 3D Viewport.

There is a post that deals with this, which makes my post a duplicate. How do I increase the render distance?

enter image description here

$\endgroup$

Not the answer you're looking for? Browse other questions tagged or ask your own question.