1
$\begingroup$

I'm trying to create more vertices in an edge so I subdivide it, but for some reason, after I subdivide it once, it decides to only select one half of the subdivide. This messes with my faces when I then try to move them to shape them into what I'm modeling.

Before subdivide: enter image description here

After first subdivide: enter image description here

After second subdivide:enter image description here

What it's supposed to look like: enter image description here

It creating a weird face under on my model:enter image description here

$\endgroup$
1
  • 1
    $\begingroup$ best practice is to avoid ngons while modeling. having ngons would cause such problems. $\endgroup$
    – Mobin
    Feb 28 at 7:50
2
$\begingroup$

It's because the face on the right is already subdivided, and so is the edge between them. You should have subdivide them both at the same time. enter image description here

You could fix this by selecting all the vertical edges between the faces and rip them (shortcut v). Then remove excess verts (select them and x -> Dissolve Vertices) on the face you're trying to subdivide. Subdivide the face. The verts on the right should allign. Now you have duplicated vertices in that region. Remove them by selecting all vers in the region (you'll probably have to turn on X-ray (alt+Z) to reach the duplicates) using Merge by Distance.

$\endgroup$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.