2
$\begingroup$

I downloaded some 3d assets from synty store, this asset pack specifically: https://syntystore.com/products/polygon-nature-pack and i'm trying to get the trees to look like the example but i see the trees with black parts and I can't figure out how to use the mask texture to hide the black parts. any help is appreciated

enter image description here

how nodes are set up: enter image description here

and this is what the texture files look like in file explorer: enter image description here


updated node setup: enter image description here and how it looks enter image description here

$\endgroup$
5
  • 1
    $\begingroup$ You have set Metallic and Specular to 1. Is that intentional? Ok, no. I just read that you want it to look like the example. Set them back to 0 and 0.5 The mask is probably for transparency. You need to plug it in the Alpha slot of the Principled BSDF and set in the material panel Settings -> Blend Mode to Alpha Blend when you are in Eeevee. $\endgroup$
    – Blunder
    Commented Feb 27, 2021 at 17:23
  • $\begingroup$ i did that and still seeing the same thing. how do i know eevee mode? $\endgroup$ Commented Feb 27, 2021 at 17:31
  • $\begingroup$ updated my question with how the nodes are set up now and what i'm seeing @Blunder $\endgroup$ Commented Feb 27, 2021 at 17:35
  • 1
    $\begingroup$ Check the render engine for Eevee and see this for Blend mode settings. Ok, I see that you solved it already :-) Eevee has a Bloom option in the render settings. The sample images seem to have made use of this. $\endgroup$
    – Blunder
    Commented Feb 27, 2021 at 17:49
  • $\begingroup$ cool thanks for the help and the links! i'm still learning all this so its very helpful! $\endgroup$ Commented Feb 27, 2021 at 18:16

1 Answer 1

2
$\begingroup$

turns out i needed to use the alpha of the main texture (not the mask texture) to the alpha of the principled BSDF. I think the suggestion from @blunder to use alpha mix also helped (but i had to use alpha clip)

$\endgroup$

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .