1
$\begingroup$

I'm having trouble rendering this scene I've made from Grant Abbitt's steampunk goggles tutorial. The thing is when I'm looking through the Viewport I can clearly see reflections from the material, but then when I go to render, the reflections look flat or barely visible.

Link to .blend file with packed textures

Screenshots: Here's how it looks in the Viewport Here's how it looks in the final render

$\endgroup$
1
$\begingroup$

Your scene environment is not set up properly. The HDRI is using an ordinary Image Texture node, not an Environment Texture node:

Deleting it and replacing it with an Environment Texture node fixes the render:

The reason the result looks okay in the 3D viewport is because it looks like you had Scene World unchecked in the scene options:

If you check that box, then the 3D viewport matches the rendered result.

$\endgroup$
1
  • $\begingroup$ Thank you! That did the trick :D $\endgroup$ – Facundo Bazzano Feb 25 at 22:26

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.