0
$\begingroup$

TLDR: Textures moved/stretched in mapping node not exporting with said transformations.

For the model I am trying to export, I have two image textures I am using. When I export as an FBX and view with windows 3d viewer all the image textures are missing or black. When I try to export to Sketchfab, the textures appear, but they don't have any of the transformations made in the mapping node. (squished, see image)

All models are UV unwrapped. I have tried exporting with auto/copy/embedded textures but nothing has worked. I've tried exporting with sketchfab addon, and uploading manually. this is what it is supposed to look like

New to Blender.

enter image description here

enter image description here enter image description here

enter image description here

$\endgroup$
1
  • $\begingroup$ The shaders aren't universal. You can't use them with other softwares. Blender will export the image textures bundled to the fbx and some of them will be used well like Color or Normals. But there will be no information about any of the nodes. So you have to fix the UV-s to fit to the original image or modify the images in an external software like Gimp to apply the transforms. Or you can bake the textures to a new image. $\endgroup$ – FFeller Feb 25 at 17:06

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.