6
$\begingroup$

My particle system doesn't seem to be using the vertex group which I set to effect the density. I am a little bit confused as to why this is happening.

Here is my blend file http://www.pasteall.org/blend/33498

Thanks

$\endgroup$
5
$\begingroup$

This is because you have a 'Multires' modifier above the 'Particle System' modifier, which is altering the geometry. Blender applies the modifiers to the object in the order they are in in the stack (see more here).

Because the vertex group gives specific vertices weights and the multires modifier changes those specific vertices, ie more are added, positions are changed etc., the vertex group has changed by the time the particle system 'sees' it.

To fix this you can either move the particle system modifier above the multires modifier (so the particle system is calculated before the multires modifier changes the geometry and sees the original vertices of the mesh) or you can check the 'Use Modifier Stack' checkbox in the 'Emission' section of the particle settings:

enter image description here

Note: Those two different methods will give slightly different results. The 'User Modifier Stack' option will act as though the multires modifier has been applied to the mesh, so the mesh will be higher resolution, potentially giving a smoother result to the particle emission. If you instead change the modifier order, the particle system will completely ignore the multires modifier and only use the original, untouched geometry to emit particles from.

$\endgroup$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.