2
$\begingroup$

Hello there!


I'm working on a game and I got Advanced Locomotion System V4 from the UE Marketplace (Here) which makes use of some really cool animation techniques that look great and has been brilliant with the default AnimMan model.


Skeleton


So, being happy with the system I set about adapting it to my character, starting with importing the skeleton into Blender and making it fit my character, as far as I can tell that went fine.

The default AnimMan model with the original skeleton. My character with the adapted skeleton.


Weight Painting


From there I moved onto weight-painting which is where the issues are coming from, I believe. Pelvis weight painting Upperarm_l weight painting Lowerarm_l weight painting Hand_l weight painting


Result + Issues


I then went on to retarget the animation blueprint in UE4 for this skeleton, the animations are working but with a number of serious issues.

Animation problems in UE4

The issues seem to be at joints, where the weight paints overlap.

Animation problems in UE4 cont.

Here the shoulders are too far forward and the back seems to bend oddly.


Conclusion


I am unsure what exactly is causing this, my only guess is that the weight paints are too sharp and need to be smoothed out a little? Any help is much appreciated and I thank all who took the time to read this.

$\endgroup$

2 Answers 2

1
$\begingroup$

When you're satisfied with the weight paint in Blender, in weight paint mode go to weight menu and use "Normalize all", and "Limit total" to 4 before exporting.

Blender accept all weight values and do an automatic normalization when some vertices sum more or less than 1.0 of total weight; exporting a non normalized paint can result in different weight ratios.

Limit total is necessary for Unity, maybe Unreal also has this limitation.

enter image description here

$\endgroup$
3
  • $\begingroup$ I tried clicking "Normalize All" and Limiting the total to 4 for all groups, then exported and did the retargeting, sadly this doesn't seem to have fixed anything and the issues still persist. I really appreciate the suggestion though, thanks! $\endgroup$ Feb 25, 2021 at 21:29
  • $\begingroup$ Did you apply (Ctrl A) all transforms of both rig and mesh objects before exporting? $\endgroup$ Feb 26, 2021 at 7:13
  • $\begingroup$ I've gone back and tried applying all transforms for both the rig and the mesh, still no dice. All that did was scale the mesh down 100 when imported to UE4, unfortunately... $\endgroup$ Feb 26, 2021 at 15:57
0
$\begingroup$

I looked at the docs and made some changes, the issue was that every bone was using animation translation retargeting. If anyone else has this issue: Open the skeleton asset and click "Options", then check the box for "Show retargeting options". Now there should be an additional column labelled "Translation Retargeting", under that will be a dropdown for each bone. Right-click the root bone and click "Recursively Set Translation Retargeting Skeleton", then set the pelvis to "AnimationScaled" and then set the root bone, any IK bones, weapon bones or other marker-style bones to "Animation".

$\endgroup$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.