0
$\begingroup$

I have a fairly simple scene with an object that had some weird artefacts due to the weird topology:

enter image description here

...which I mitigated by separating it into 2 standalone objects, hoping that'd give me a cleaner render:

enter image description here

But every time I render in both Eevee and Cycles (the final render needs to be in Eevee) I keep getting the old render (see first image) that won't reflect the changes I made.

I've come across threads mentioning how disabling the Sequencer option in the post-processing tab should fix it, but I still have the issue even with it disabled. Which is weird as I only have audio strips in my Sequencer:

enter image description here

Any help in troubleshooting this would be massively appreciated!🙏🏾

[Edit]

After trying to troubleshoot it, the issue doesn't seem to be related to the sequencer, but the actual material, which seems to be blending with an unrelated PBR one in my file. (SSGI v1.4 addon enabled for context):

enter image description here

$\endgroup$
2
  • $\begingroup$ I don't think this has anything to do with the VSE. Are you sure you haven't duplicated the objects (on top of eachother) in stead of separating them? You can find the offending object easily by disabling the "Disable in Renders" (the camera icon) one by one in the outliner and check the render. $\endgroup$ – Husch Feb 25 at 12:39
  • $\begingroup$ Thanks for the reply, I've tried toggling things on and off from both the viewport and the final render and still nothing. I've literally taken off the top (dial) part to see if it'd update on the scene and it still shows up on final render. I'm running Blender 2.91.0 and not sure if this is an issue that's been fixed cuz I'm losing my mind 🤯 $\endgroup$ – Abraham S. Feb 25 at 12:45
0
$\begingroup$

Seems like you have double geometry. Try selecting the object and moving it to see if you have overlapping objects or entering the Edit mode and selecting an island of geometry with L while hovering mouse over it to see if you have double geometry in a single object. It may also be that the double geometry is connected so you might need to grab a face or an edge and move it to see if they have duplicates beneath.

$\endgroup$
1
  • $\begingroup$ Thanks so, so much for the detailed suggestion. I've had a closer look at the scenes, as I had duplicates that were disabled in view, but not in render, as well as some pesky active (Boolean) modifiers that I'd left active. None of them seemed to have double geometry though. The orange artefact also seem to inherit another (fabric) material, which means it might be a separate object altogether. For now I've deleted an unnecessary object, which seems to have helped. Thanks so much again! $\endgroup$ – Abraham S. Feb 25 at 16:39

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.