0
$\begingroup$

I have two softbody cubes, one is smaller than the other. They are both aflling at the same speed, but the problem is that when the bigger cube lands, the smaller cube goes all the way down. Is there a way to keep both cubes' position the same?

enter image description here

I want them to be in the same position.

blend file

$\endgroup$
8
  • $\begingroup$ I will be sleeping when this question is answered, I will accept any answers in the morning.. thanks :) $\endgroup$ – Clobro Feb 23 at 5:25
  • $\begingroup$ You could try adding a second collision floor so that the middle softbody lands in the right height you want. Just make sure to change the collision layer. $\endgroup$ – Nascent Space Feb 23 at 6:33
  • 2
    $\begingroup$ Please edit your question to include more detail and/or screenshots to illustrate the setup and situation without requiring someone to download and open the Blend file. $\endgroup$ – Rich Sedman Feb 23 at 8:45
  • 1
    $\begingroup$ It is not clear to me what are you trying to achieve? $\endgroup$ – vklidu Feb 23 at 10:54
  • $\begingroup$ Your .blend file is doing exactly what it's supposed to do. Do you want the small cube to NOT impact the collision cube? To stay at the centre of the larger, softbody cube while the larger cube does it's impact? Do you want the smaller cube to react as though it hit something? Or just wobble like it's trapped inside the larger cube? $\endgroup$ – Psyonic Feb 23 at 11:25
2
$\begingroup$

Two options:

  1. Assign all verts in BigCube to a vertex group. Give SmallCube a copy location constraint, targeting BigCube and referencing this vertex group. Give SmallCube a healthy Goal value (or group).

  2. Join BigCube and SmallCube into a single object. Create edges (only) between BigCube and SmallCube to create forces between the two. These will act as any other soft body edges, seeking to maintain their length (and possibly, with positive soft body bending values, lengths to neighbor verts), causing SmallCube to prefer to float inside of BigCube rather than fall completely to the ground.

$\endgroup$
2
  • $\begingroup$ For some reason, only smallcube falls when i do the second option, and I don't know how to do what you said in the first one. $\endgroup$ – Clobro Feb 23 at 16:21
  • $\begingroup$ nevermind, I got it to work by clearing the bake cache, thanks! $\endgroup$ – Clobro Feb 23 at 17:10

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.