2
$\begingroup$

Screenshot showing the issue

I'm trying to position the spheres in a way they are located above the surface (as if they were metal balls thrown on top of a table). I was attempting to do so through the use of particles, since it was something I haven't used in a while as a way of object dispersion. However, the particle objects were displayed passing through the middle of the surface (half above, half under).

I checked how to fix the issue and every source I looked into said the solution was to change the origin of my sphere. Sure, I had left it on the middle of the sphere. Then I changed it... However, it didn't fix the problem at all. As you can see in the image, the source of the particles (the selected object) does have it's origin set to the bottom, but it's still being placed as if the origin is in the middle.

Is this a bug? Did I miss some step? Have I done something wrong? I'm a bit annoyed here because I expected it to be a simple study but this is a mockup I have to send very soon.

As a side note, English is not my first language and the naming of Blender's menus often leaves me quite overwhelmed (it can be a bit hard to be showered with technical idiom not on your language), so I'll appreciate if answers are a bit more on the illustrative side. Thanks in advance!

$\endgroup$
2
  • $\begingroup$ Easy way, just move the object used for particles up slightly. Thorough way, turn off velocity and gravity or set it to hair. Set particle spawning to start at 1 and end at 1. $\endgroup$ Feb 22 '21 at 23:15
  • 1
    $\begingroup$ @NascentSpace It's was already set to hair. However I managed to fix it in the velocity menu changing object alignment. Thank you! $\endgroup$
    – araralc
    Feb 22 '21 at 23:26
1
$\begingroup$

Objects used as hair particles do not view Z+ as "up". They must have a different orientation, for some legacy reason coming from the particle system's beginnings, afaik.

Model and texture your object, align it at the origin as though you were aligning a regular object on a ground plane. Exactly as you have in the image you've presented. Then, with the object selected, press R + X + -90 to rotate the object -90 degrees on the X axis, and then press Ctrl + A and apply the rotation.

$\endgroup$
1
  • $\begingroup$ Thank you. I noticed the origin was setting the object to move sideways when setting particles (comparing to when the origin was in the middle), as if the particles were considering the origin but rotating the object 90º, but I thought it was just a wrong impression from me. So that was really what happened. I managed to fix the issue on improvisation but this is really helpful for next time I need to do something similar. $\endgroup$
    – araralc
    Mar 6 '21 at 22:40

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.