6
$\begingroup$

I am trying to render a video (that is not a .dvd file) with audio using Blender. So far, I haven't had any success; all of my rendered clips have had the audio missing from the playback. I've tried a couple of different encoding and output options but nothing has worked so far (except for a .dvd file that I rendered originally).

What are my options for rendering a video with working audio?

$\endgroup$
7
  • 1
    $\begingroup$ Can you please elaborate? How did you add audio to your scene? Which audio codec did you tried, in conjunction with which video codec? $\endgroup$
    – Polosson
    Commented Dec 22, 2014 at 20:30
  • $\begingroup$ In addition to what was already asked by Polosson, which player do you use? Have you tried VLC (videolan.org/vlc) it would probably best to add a screenshot with all settings. $\endgroup$
    – stacker
    Commented Dec 22, 2014 at 21:30
  • $\begingroup$ @Polosson So the audio was included with the video clips that I imported into Blender. I didn't import the audio separately from the video. Here is a link to some screencaps displaying some of the output/encoding options I tried out (it goes to a deviantart page; just an fyi): sta.sh/0pb1dwup78 $\endgroup$
    – AAC
    Commented Dec 22, 2014 at 21:47
  • $\begingroup$ OK, but... where did you import that video? in the VSE? in the MCE? as a input node in the compositor? as a background animation in the 3D viewport? Please tell us more about your setup, and add some screenshots if you can. $\endgroup$
    – Polosson
    Commented Dec 22, 2014 at 21:50
  • $\begingroup$ @Polosson I imported the video using the VSE. As for my setup, I'm not entirely sure what sort of information you need (I'm new to Blender and new to video editing so I'm not sure what kind of information is needed). As to why I'm using Blender for video editing...It's free. $\endgroup$
    – AAC
    Commented Dec 22, 2014 at 22:11

4 Answers 4

10
$\begingroup$

Open a Properties Pane.
Scroll down until you see the "Encoding" dropdown tab.
You'll see Audio Codecs. If "None" is selected, there will be no audio.
Here is an example.
Blender example

enter image description here

$\endgroup$
2
  • $\begingroup$ Ayyyy is that Yugioh? $\endgroup$
    – L0j1k
    Commented Oct 17, 2017 at 22:28
  • 2
    $\begingroup$ Actually, the MLP CCG. $\endgroup$ Commented Oct 19, 2017 at 2:16
0
$\begingroup$

As someone who has some experience with encoding video, I couldn't believe how hard it was to find a solution for this.

What worked for me was:

  1. Add the video as an image texture in the Emission material - basically follow the Olav3D tutotrial.
  2. Open the image using the picture button of the mountain and sun, in UV Editing (not the Open file)
  3. Wrestle with getting the image on to the surface I wanted. This consisted of rotating the image and moving the corners of the UV map to where the image was.
  4. Adjusting the correct frame start and end
  5. Switch on MP3 Audio in the Rendering tab.

This is where I figured it out...

  1. Add the Video Editing menu, by pressing the "+" on the menu bar.
  2. Add the video, and moving the sound and video strips, to start at 0. Just drag and drop.
  3. Delete JUST the video strip, leave the sound strip.
  4. Check the video plays in Render View, adjust cameras etc.
  5. Wonder why no one explained this ever on the internet and post to Stack Exchange.

I hope this works, if not I can post pictures. Good luck.

$\endgroup$
3
  • $\begingroup$ 10. because they would get downvoted into oblivion :) you just need to start a new Video Editing file, drop your video in the sequencer, select a video and audio codec and hit render $\endgroup$
    – pevinkinel
    Commented Sep 18, 2020 at 21:39
  • $\begingroup$ I don't mind deleting this if you think it will lead people astray - especially if there is a nicely documented guide available. $\endgroup$
    – KK_
    Commented Sep 18, 2020 at 22:07
  • $\begingroup$ maybe? up to you really. since the question is just about enabling audio (and to be fair that's already been asked and answered multiple times on this site), I doubt many ppl will come across your answer when trying to import video, which is the part of your answer that's convoluted. My comment was just to make your life easier next time you import a video :) $\endgroup$
    – pevinkinel
    Commented Sep 18, 2020 at 22:34
-1
$\begingroup$

The solution comes from Richard Antalik, at developer.blender.org

Enable Sequencer in Output Properties > Post Processing panel.

In Blender 3.0 the Output Properties (tab) is where you define the size of your output, where to output your file to, encoding for video and audio, etc. You will also find in the same tab the Post Processing panel with compositing and sequencer check boxes. Put a check on the Sequencer.

$\endgroup$
1
  • $\begingroup$ Hello and welcome. Please don't post the same answer more than once, if the questions are the same instead vote to close them as duplicates, thanks. $\endgroup$ Commented Jan 17, 2022 at 11:48
-1
$\begingroup$

Running Blender from the terminal with --verbose I was notified that the audio fails because of a problem with ffmpeg (I'm using ffmpeg from packman repo on opensuse leap 15.4 instead of from the opensuse repo).

$\endgroup$

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .