1
$\begingroup$

Problem: Blender 2.91.2 crashes when I open my file.

New files work fine, and other older files also work fine.

But the file that I’ve put several weeks work into no longer opens. I have backups of the file - they cause blender to crash too! Something has changed but I don't know what.

I read some other reported fixes - I tried erasing user preference files. I even totally reinstalled Blender - on TWO platforms (MacOs and Win10). On BOTH platforms my files cause an immediate crash. This is after working fine for weeks. Note: I did try to APPEND objects from the file as an emergency last ditch recovery - appending some objects works others cause the crash again.

Below is some debug info. (There is a lot more of that if helpful)

My main machine is a MacOs BigSur 11.2.1 -> but again I’m having the SAME problem on Win10 too (with this file).

Any help would be most appreciated.

Thanks, Matt

Process:               Blender [1956]
Path:                  /Applications/Blender.app/Contents/MacOS/Blender
Identifier:            org.blenderfoundation.blender
Version:               2.91.2 (2.91.2 2021-01-19)
Code Type:             X86-64 (Native)
Parent Process:        ??? [1]
Responsible:           Blender [1956]
User ID:               501

Date/Time:             2021-02-20 20:54:52.355 -0800
OS Version:            macOS 11.2.1 (20D74)
Report Version:        12
Anonymous UUID:        A3EEC5E4-BEF6-9A17-3D99-BCEE0C55A7F4


Time Awake Since Boot: 2200 seconds

System Integrity Protection: enabled

Crashed Thread:        0  Dispatch queue: com.apple.main-thread

Exception Type:        EXC_CRASH (SIGSEGV)
Exception Codes:       0x0000000000000000, 0x0000000000000000
Exception Note:        EXC_CORPSE_NOTIFY

Termination Signal:    Segmentation fault: 11
Termination Reason:    Namespace SIGNAL, Code 0xb
Terminating Process:   Blender [1956]

Application Specific Information:
dyld: in dlopen()
/System/Library/PrivateFrameworks/GeoServices.framework/Versions/A/GeoServices

Thread 0 Crashed:: Dispatch queue: com.apple.main-thread
$\endgroup$
6
  • $\begingroup$ If you already tried backups and appending and you are not able to separate corrupted parts I don't think you have a chance. Anyway ... Have you tried to ... open file in older or newer version? ... open under Catalina? ... when you say Win10 - do you mean on PC or virtually on Mac like Boot camp? ... what kind of objects make it crash? $\endgroup$ – vklidu Feb 21 at 7:09
  • 1
    $\begingroup$ Also try to run blender from Terminal.app blender.stackexchange.com/q/102860/2214 to see console report. $\endgroup$ – vklidu Feb 21 at 8:42
  • $\begingroup$ thank you for your quick response. I tried a previous version (2.90) and also the new 2.92RC. both crashed on this file. Also when I mentioned Win10 that was on a separate and normal x86 PC running Win10 and Windows Blender version - my file crashes there too. I also ran from the terminal app (good idea!) and captured this among other things: "zsh: segmentation fault /Applications/Blender.app/Contents/MacOS/Blender" $\endgroup$ – MattG Feb 21 at 18:28
  • $\begingroup$ I'm now starting the process of reconstructing my file using Append and pulling in collections to a newly created file. One collection worked! The other two cause the crash even with append. this is really so odd. so now i'm going object by object to find what is going on. this is really strange! have used Blender for many years and never had this sort of issue. $\endgroup$ – MattG Feb 21 at 18:32
  • $\begingroup$ "segmentation" ... yes that sounds like reading structure issue ... so I would say you are lucky you can appending parts of file :) But I could be wrong. $\endgroup$ – vklidu Feb 21 at 19:50

Browse other questions tagged or ask your own question.