10
$\begingroup$

I am trying to bake a fluid simulation in Blender 2.67. Here is a mockup of my scene:

enter image description here

My scene is set up just like the picture, with a sun lamp above a mesh that is supposed to be a riverbed.

The liquid Domain object encapsulates everything except for the sun lamp, and it covers all edges. Inflow and outflow objects are specified, one each, with the inflow velocity set to Y: -1.0, Z: 1.0. All liquid simulated objects are enabled. The mesh is set to Obstacle. Settings are very, very low: 25 resolution for final and preview, 4.0 second start/end span for 100 frames (real-time), and smoothing set to 0.0, for a whopping 463 KB estimated memory space.

My issue is that when I try to bake it, after specifying a valid directory, nothing happens, except that the status bar appears, my computer saves the baked cache correctly, and then it's as if nothing happened. Nothing in the menus changes, preview and render both act as if the event never occurred. I'm also using Windows 7 64-bit with Intel Mobile Express Chipset Family 4 (graphics card).

That's not a lot, so I know it can't be my memory or graphics card issues. Here is the relevant .blend file. What could the problem be?

$\endgroup$
9
$\begingroup$

I don't use the fluid simulator much but it seems the problem can be fixed by adding some depth to the inflow object. Currently it's just a flat plane. Just extrude it a bit on the Y axis and bake.

enter image description here

$\endgroup$
  • $\begingroup$ I extruded both the inflow and outflow objects out by 0.05. Then I located my (completely empty) cache folder and baked. I did absolutely absolutely nothing between these steps. Blender again outputs the files to two folders: Fluid and FluidTest1_. I then press play on the timeline and in preview, render, wireframe, object, and textured mode I see no sign that water ever existed. It is starting to look like a file-location error (or even a bug). $\endgroup$ – person27 Aug 4 '13 at 2:17
  • $\begingroup$ @Stopforgettingmyaccounts I did nothing to the file except extrude the inflow object. Turn your preview and final settings up a bit.. try 60. I don't think 25 will show. You can also try deleting the cache folder before baking again. $\endgroup$ – iKlsR Aug 4 '13 at 2:20
  • 1
    $\begingroup$ @Stopforgettingmyaccounts... Ok, great. In conclusion.. as I said before.. answers need to be self contained and people need to know exactly what they are doing to see where they went wrong etc. so poking around a modified file makes little to no sense and is not as helpful as actually guiding the person through the steps. $\endgroup$ – iKlsR Aug 4 '13 at 3:45
  • 2
    $\begingroup$ I feel Blend file can be valuable as a troubleshooting step, narrowing down the problem, etc. But yes, in this case, the answer is: Fluid inflow needs to be a volume, so modifying the inflow plane into a cube works. $\endgroup$ – Mike Pan Aug 6 '13 at 2:45
  • 1
    $\begingroup$ @MikePan In some cases yes. What I mean is use them as examples for questions/answers but not as 'fixes' to problems, that really helps nobody. See meta.blender.stackexchange.com/a/169/12 $\endgroup$ – iKlsR Aug 6 '13 at 3:11
1
$\begingroup$

I had the same problem and for some reason when you scale down the Fluid object it stops baking, so I had to scale it up for it to work. Now that might mean that you have to bring up the resolution for small fluid objects. That at least worked for me! Hope it helped.

$\endgroup$
  • $\begingroup$ It doesn't stop baking if Fluid object is small, it might be that resolution of simulation is not enough to preview the baked results and appears to be absent. $\endgroup$ – Mr Zak Jul 25 '17 at 13:26
1
$\begingroup$

I had a similar challenge, try the following: 1. select domain object and press tab to enter edit mode, then subdivide. 2. press tab again to enter object mode, click subdivision modifier and increase render to 2. Bake and watch it simulate.

$\endgroup$
0
$\begingroup$

I also had this problem and solved it by changing the directory of the cache_fluid - files. Maybe the path was too long, I don't know, but after I changed this to my desktop it worked just fine.

$\endgroup$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.