4
$\begingroup$

I am trying to apply a texture to to my model, but it isn't working and I don't know what I am doing wrong.

I UV Mapped the model and colored my texture to fit to the model. When I am in Texture Paint mode the model looks fine, but when I switch to Object Mode the model becomes white, and I can't figure out why...

Here is Texture Paint Mode:

Texture Paint

Here is Object Mode:

Object Mode

Does anyone have any suggestions?

$\endgroup$
7
$\begingroup$

Textures aren't displayed in Solid view by default. You can either switch to a higher level shading view which displays textures, such as textured view (⎇ AltZ). Or you can enable Textured solid in 3D view > Properties region (N) > Shading:

enter image description here

Note that this doesn't affect the final render, only the viewport.

See the wiki for more information.

$\endgroup$
  • $\begingroup$ I want to export it to fbx then import it into unity and supposedly it has to be on the object is what I have read... $\endgroup$ – Get Off My Lawn Dec 22 '14 at 1:43
  • $\begingroup$ @RyanNaddy If you've assigned it as a texture in the texture panel then it should work. (It looks to me like you have, as it seems to be appearing in the render preview in the materials panel) $\endgroup$ – gandalf3 Dec 22 '14 at 2:27

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.