1
$\begingroup$

I've got a scene where I'm trying to get a cube, to travel at high speed and collide with another cube, I'll call them cubeA and cubeB. I animated cubeA to start far off in the distance, away from my camera's vision (so its not visible earlier on in the animation), then to pop in closer, and move towards cubeB which it is supposed to be colliding with.

I've applied rigid body physics to both cubes (and the plane underneath them), and keyframed the 'animated' and 'dynamic' properties so that they start animated, a frame before I want the simulation to start I have another keyframe of it being animated, and then there is a keyframe setting it to dynamic. (CubeB's keyframe setting it to dynamic happens a bit earlier than cubeA)

However, for the cubeA, when the physics simulation starts it just teleports to its original location, and stays there, it doesn't even fall because there's nothing underneath it at that location, even though on that same frame as the simulation starts it has a keyframe for an entirely different location. I've tried moving this location keyframe to the frame before the simulation starts, but it didn't seem to fix the problem. I don't know whether this happens with cubeB because it stays in its original location the whole time.

Previously I had problems with the physics simulation rotating my textures, but I think i fixed it by applying my scale. I don't know if the two problems are linked.

The cube's materials contain peoples faces, as this project is an intro for a YouTube channel, so I've taken screenshots in solid view:

cube is out of view of camera before animation

cube is animated

frame before physics sim

physics sim has started

cube at start of physics sim Image 1: Cube is out of view of camera before animation

Image 2: Cube is animated

Image 3: Frame before physics sim

Image 4: Physics sim has started

Image 5: cube at start of physics sim

I did a save as to a new blend file so I could add it to the question, and the cube no longer teleports. Now, when the physics simulation starts, it just stays where it is and doesn't move, and doesn't hit the other cube. I just have no clue anymore!

enter image description here

The file can be found here

$\endgroup$
3
  • $\begingroup$ Here is a wetransfer link to the blend and blend1 files: we.tl/t-mhE82MBnR3 $\endgroup$ – Sam Moshi Feb 18 at 21:00
  • $\begingroup$ It probably had a cache or a bake that wasn't properly updated to scene changes and didn't preserve through save/load. $\endgroup$ – Nathan Feb 18 at 21:17
  • $\begingroup$ I've done a bit more testing and it seems like that's the problem. How would i fix it? $\endgroup$ – Sam Moshi Feb 19 at 11:55
0
$\begingroup$

I am new too, but I think the answer is that you enable the "animated" not to just being keyframed, but entirely throughout the animation. I hope this helps!

$\endgroup$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.