enter image description hereI am fairly new to Blender.(I am an experienced Maya 3D artist)enter image description here I'm using version 2.83 on an iMac. I have rendered simple 3D models before using blender and the Eevee engine. But I need to test motion tracking and photo realistic 3D car rendering for work. I have followed a good motion tracking and rendering tutorial on youtube, but since I have the motion tracking figured out and scaled correctly with my car model, it will not render. If I add a sphere to the scene it will not render. The only thing that shows up in my renders is the image sequence background that I used for the motion tracking. I have checked my render layers, the car is render enabled. The Cycles render engine is selected. I can see the car in the viewports, but it never renders! Can someone please help? I am attaching a screenshot.


When you press "setup tracking scene" after solving the camera movement, blender creates two collections: a foreground (with a cube as reference) and a background (a plane to catch shadows).

You can safely delete the background one if you don't need a shadow catcher.

See: https://blender.stackexchange.com/a/108876/92768

  • $\begingroup$ Thanks for the reply, but I think I figured out the problem. It seems that I started my motion tracking project having already had a car model in my scene. When I followed the motion tracking tutorial it disabled the render abilities for the car model somehow. So I started the tutorial again with an empty scene, and then appended my car model into the scene after the tracking and camera solving. This worked! I can now render my car and its shadows. $\endgroup$
    – LemonHat
    Feb 19 at 10:43
  • $\begingroup$ @LemonHat all that you need to do is incorporate the collection where the car is to the rendered collections, or add a node in the compositor to have the contents of the collection where the car is so that the information can be available for compositing. No need to do things over. $\endgroup$
    – susu
    Feb 19 at 16:45

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.