2
$\begingroup$

So i was working on a model for my school project, and it was all going well until this happened. I can see the armature in object or pose mode, but if i switch to edit mode, the armature dissappears. I can still see the origin of the armature, and all the animations are still playable, there isnt anything wrong with the armature i think, but in no way you can edit the armature. I tried googling about this issue, but apparently no one had such problem like i am having right now.

The armature is not hidden in any way, maybe its a bug, i have know idea. I wish i had a copy of this model to which i can always go back, but i guess i learned my lesson this time.

Here is the armature in object mode where it is visible:enter image description here

Here is the armature in edit mode where it is not visible which is the reason why it cannot be edited, the origin point is still visible so i guess its still there. enter image description here

I dont know how i got this problem, i was just working with the animations and was switching over to edit mode and couldn't see the armature anymore, very strange. If this problem persists i guess i'll just have to keep working on the model with the armature that i have lol.

Any help is appreciated, Thanks :)

Btw english isnt my best language so sorry for any mistakes.

$\endgroup$
2
  • $\begingroup$ May be the bones are hidden. Press alt+h. $\endgroup$ – FFeller Feb 14 at 18:52
  • $\begingroup$ Dude, honestly i didnt think it would work but it actually did. lol. i think i definitely tried alt-h, but dont understand why it didnt work then. anyway, thanks. i would never even think of alt-h but that just was the problem. $\endgroup$ – CodeerBeer Feb 14 at 20:14
1
$\begingroup$

Guess what... im holding another Major L, @FFeller just told me the solution, i thought it wasnt gonna work cause i just did so much other stuff to figure this out so i didnt thought this small thing can be the fix, but it was. Just pressed Alt + H. Veeerry weird why it didnt work earlier before i posted this question, cause i obviously have tried pressing alt+h, or maybe thats what i think i did and its just me being dumb.

$\endgroup$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.