0
$\begingroup$

Thank you for taking the time to help. I have a model in my Blender workspace that came from the source subdivided into four individual meshes/armatures/materials. I merged the meshes into a single mesh, and set up the new, single armature the way I wanted it. I exported the collection as an FBX, but when I import that FBX into other programs, it's still showing up as four separate meshes. How do I get Blender to export the collection as a single mesh/armature?

$\endgroup$
10
  • 1
    $\begingroup$ You have to join the meshes in Blender before exporting (CTRL+J). If you need the originial separated parts duplicate them before joining. $\endgroup$
    – FFeller
    Feb 12, 2021 at 18:50
  • $\begingroup$ I had already joined the meshes and armatures in Blender using CTRL+J. They look correct in my Blender workspace, and they behave correctly in Posing mode, but when I export it, it exports it as four separate meshes in one FBX file. $\endgroup$ Feb 12, 2021 at 19:24
  • $\begingroup$ Please share your file here: blend-exchange.giantcowfilms.com $\endgroup$
    – FFeller
    Feb 13, 2021 at 16:33
  • $\begingroup$ Done! Here's the link: blend-exchange.giantcowfilms.com/b/gGW1lvMx $\endgroup$ Feb 13, 2021 at 18:34
  • $\begingroup$ This file contains only one mesh (I tried it in Unreal Engine too), but there are 4 material slots on it. So you have to assign 4 materials to it in any software (probalby thats why you see separated parts). You can remove the unnecessary slots in Blender, but it will cause overlapping UVs, so you have to repack the UVMap if you want to use it with only one material. $\endgroup$
    – FFeller
    Feb 13, 2021 at 18:45

1 Answer 1

1
$\begingroup$

Like FFeller mentioned, select all the objects, right-click, and press Join. Make sure you shift click one of the objects so that at least one of them is selected, otherwise it is impossible to join them.

In the FBX export screen, there will also be an option to export only "Selected Objects", or just the "Active Collection".

Select the objects and collections you have to export, and tick both of those. If are still having problems, maybe export the objects as OBJ and everything else as FBX.

$\endgroup$
3
  • $\begingroup$ Thanks! I already joined the meshes and set up the armature to where I needed it to be, and tested it in Blender. It's not exporting correctly, however; I get four separate meshes in a single FBX file $\endgroup$ Feb 12, 2021 at 19:25
  • $\begingroup$ Are you importing these into Unreal? If so, tick "Combine Meshes" in the FBX import screen. If it's not UE, then I'm not sure. $\endgroup$ Feb 12, 2021 at 19:54
  • $\begingroup$ No, I'm importing them into Poser, but it has to be a problem with the Blender export, because the same thing is happening in other software. $\endgroup$ Feb 12, 2021 at 20:27

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .