5
$\begingroup$

So I have been extruding a cube to make a low poly banana and when I go from edit to object mode half the edges don't appear as well as half is dark.

enter image description here

enter image description here

I tried looking for an solution couldn't find one and its making me feel like I am doing something wrong so I decided to come here.

$\endgroup$
2
  • $\begingroup$ Mirror modifier? $\endgroup$ – Scalia Dec 20 '14 at 1:25
  • 1
    $\begingroup$ The normals look like they are switched. Tab into edit mode, press A to select all, and then press Ctrl+N. $\endgroup$ – VRM Dec 20 '14 at 1:35
9
$\begingroup$

This is normal, as you are in wireframe mode. By default not all edges are displayed in wireframe mode.

To display all edges, enable Draw All Edges in Properties > Object > Display:

Or you could switch to solid view by pressing Z.

$\endgroup$
3
$\begingroup$

What you are experiencing is normal behavior. Unless you have certain modifiers that add geometry (subsurf, remesh, etc.) Blender will not show edges between nearly coplanar faces in order to make viewing easier. The reason that the edges are showing on the left end of the banana is because the normals are flipped, that is why the faces are darker as well.

Normals basically tell Blender what direction the faces point. To fix the normals you can select the faces with flipped normal and hit Ctrl+F > flip normals, or select all (A), and hit Ctrl+N to recalculate normal.

$\endgroup$
1
  • $\begingroup$ the different grayscale shades across the polygons in Edit mode do look a lot like inverted normals. $\endgroup$ – MarcClintDion Dec 20 '14 at 5:12

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.