Total newb. Ubuntu 18.04 Blender 2.91. Uninstalled all previous versions and did a clean fresh install from download.

I've been over this most of the day in these posts and in the documentation, my goal is to simply round the edges of a primitive. The simple method I found via various sources is to create and subdivide the object, then apply a shrinkwrap modifier and set the offset. Here is what happens.

-Create default project cube, subdivide 10 (at first, then tried subdividing multiple times per posts about having enough surfaces.)

  • Apply shrinkwrap modifer and select the target, but it doesn't allow selection.

Attempt t0 add shrinkwrap

(Side note, I do see the Material attached to the first cube, it must be the default. Tried it with and without material attached to the object.)

After trying a few dozen times and digging through more posts and documentation, I found that if I create multiple objects in the collection it allows me to select one of the other objects but the shrinkwrap applies to the FIRST object and incorrectly.

In the screen shot below, "Cube" is the first object and "Cube.001" is the second. I moved Cube aside, created a new cube, and target the second cube with the first's modifier. The result is the modifier is now applied to the first cube (not the target!) and reduces it to a no-dimension object designated by the orange outline select. Note the dimensions pane in this screen shot. You can't see it here, but the offset is set to 0.33mm in the second shot, played around with that a bit.

Screen shot 2, two objects

Remove the modifier the first object re-appears. I also tried, as in many posts, not dividing the cube in advance any applying a Subdivision Surface modifier above the shrinkwrap. What could I be missing? A simple rounding of the cube is all I'm after.

  • $\begingroup$ Sorry, if all you are after is a rounded cube, is there some specific reason you are using a shrinkwrap modifier? I think the easiest way is to add a bevel modifier, increase the segments to something like 3 or 4 and then add a Subdivision surface modifier set to something like level 2 - rounded cube done! $\endgroup$ Feb 10, 2021 at 23:15
  • $\begingroup$ Hehe Thank you! Right after I posted this I went back and deleted the shrinkwrap modifier and while the subdivision surface modifier was still active, I saw it also rounds the corners. With less subdivisions it's almost there. I played with bevel too, I could use either in a pinch but am having issues getting the right radius. I'll need the shrinkwrap for other applications, the modifiers should work as described and there is probably something I'm doing wrong. As mentioned I followed several tutorials as to the "right way" to do this, several of them are using the shrinkwrap approach. $\endgroup$
    – SdBill
    Feb 10, 2021 at 23:27
  • $\begingroup$ Sorry, just saw your comment. If anything in my answer is helpful, let me know and I'll expand on it. In the meantime, I'll investigate the shrinkwrap solution. $\endgroup$ Feb 10, 2021 at 23:29

1 Answer 1


If you just want a cube with rounded corners, the easiest way is to add a bevel modifier, increase the segments to something like 3 or 4 and then add a Subdivision surface modifier set to something like level 2:


If you want the whole cube to be round (like ballooning out), use a Subdivision Surface Modifier, followed by a Cast Modifier set to cuboid:


If you want the edges and corners rounded (like dice), inset every face slightly, and then add a Subdivision Surface Modifier:



  • $\begingroup$ Marking as answer because it does solve the root problem and so much more simple, as mentioned in comment above. Not sure why there are so many tutotials on using the shrink wrap method. Do you have any insights as to why the shrinkwrap isn't working? $\endgroup$
    – SdBill
    Feb 11, 2021 at 18:42

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .