0
$\begingroup$

I've got a spline to which I assign a color ramp along its length, so that its color varies continuously from (let's say) blue to red from one end to the other. So far, everything ok. Now I remove a segment on the spline, but now what I see in the render is something quite different: each 'subspline' (i.e. each part of the original spline) start with blue and goes to red. What I want is just the original spline going from blue to red with a missing segment, but what I get is two splines each of which go from blue to red.

Any hint as how to solve this will be greatly appreciated.

Edit: Someone suggested I added detail about how I got the colouring along the length of the curve. This link explains it; I've followed that (the selected answer) to the letter to achieve it.

$\endgroup$
6
  • 1
    $\begingroup$ I presume you're using UV coordinates to convert the distance along the spline to the input of the color ramp. It would be useful to edit your question to include additional details of your setup (including images of your nodes, geometry, etc.) to be more specific of your situation and issue. This will help others to understand your problem. $\endgroup$ Feb 10, 2021 at 16:55
  • $\begingroup$ I'm sorry, is my description not clear? $\endgroup$ Feb 10, 2021 at 17:31
  • $\begingroup$ I think I understand your situation. I was just offering suggestions on how to add to your question to make it more accessible and understandable as this will increase your chances of getting someone able to help. Adding some pictures would remove any doubt as to how you've set this up. $\endgroup$ Feb 10, 2021 at 17:37
  • $\begingroup$ I didn't include more detail into how I got the coloring working because I didn't think there were other ways of doing the color-ramp along the length. The point is: everything works ok for a spline (so I think I got the "color-ramp along the length" part right) it's with splines with missing segments that it falls apart. $\endgroup$ Feb 10, 2021 at 17:40
  • $\begingroup$ I use StackExchange a lot and from what I've seen and read, many overstated questions (bloated with too much detail and peculiarities) tend to not get an answer; people who can actually properly answer just don't want to (and most often don't need to) read a lot to give you a hint in the right direction. That's why I tend to keep questions simple, and include the minimum info required. $\endgroup$ Feb 10, 2021 at 17:42

1 Answer 1

1
$\begingroup$

The simplest solution is, don't delete spline segments. If you want part of your spline to "not exist", then use its UV to make these parts hidden, or use a mesh object with a curve modifier to create your spline:

enter image description here

Once you delete spline segments, Blender no longer has an understanding that the newly separated splines have any particular relationship to each other, and cannot draw a colorramp along their length.

$\endgroup$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.