4
$\begingroup$

I was following a tutorial online and ran into an issue with my system. (Using EVEE for the render) I have a noise texture mapped into a emission shader then connected to the volume on the material output. I get these strange overlapping triangles instead of the look that the tutorial has. I have also increased the end and put the tile size to 2px in the volumetrics. I have included a screenshot. My system is a Dell precision T7500 with an Nvidia K4000. This happens on all versions of Blender that is final releases. Thanks. enter image description here

$\endgroup$
2
  • $\begingroup$ You should add a screenshot how you wanted it to look. Thanks $\endgroup$ Feb 10 at 8:54
  • $\begingroup$ It shouldn't look like that at all. even at default settings I get sevearl overlapping planes with a noise mapped on it. Look at this tutorial --> youtube.com/watch?v=8weB_8AHYMU $\endgroup$ Feb 10 at 9:25
2
$\begingroup$

You need to reduce the 'End' setting to increase the number of volumetric 'slices' that are cutting through your volume.

Eevee renders volumes by effectively sampling a number of "slices" through the volume and combining the results. The samples are spread throughout your scene starting from the 'Start' volumetric distance and ending at the 'End' volumetric distance. By having your Start and End very far apart you are spreading out those samples and effectively wasting them over parts of your scene that don't include volumetrics.

Reduce your End until you just start to see your volumetrics "clipping" out of view (I'm guessing it will be around 5-10 (rather than 1000 that you have set). This will concentrate the volumetric rendering within your actual mesh rather than far beyond it - thereby drastically increasing the detail within your volume.

It's hard to tell scale from your screenshot - I'd assumed it was perhaps the default cube. Anyway, the key is to set Start and End each to just before it starts clipping your volume - so reduce End until you just start to lose some of your volume and then increase it slightly so it appears again. Then increase Start until it also just starts clipping your volume - then decrease slightly again so it just reappears. This way the Start is just on the boundary needed to see your volume while the End is also on the far boundary.

Note that if you're using the Viewport, the Start and End are in relation to the current view position in the scene - moving the viewport will potentially move your volume outside the Start/End clipping range and your volume will disappear. Same applies to camera view and when rendering.


Discovered during investigation that there seems to be a bug when the volume is purely emissive - adding any density changes the behaviour in ways it should not. Reported bug https://developer.blender.org/T85778 to allow this to be investigated as it results in odd results when adjusting the Start/End and/or Distribution Volumetrics settings.

$\endgroup$
9
  • $\begingroup$ I set the end to 5 and nothing shows at all. It only works at 100 or higher. $\endgroup$ Feb 10 at 9:23
  • $\begingroup$ @user3490906 I've added an edit to my answer. It's hard to get scale from your screenshot (I'd assumed default cube). The key is to tweak Start and End to concentrate the volumetric render just onto your volume. $\endgroup$ Feb 10 at 9:28
  • $\begingroup$ Actually, I think you might have hit upon a bug in the Start/End limits when using a purely emissive shader... If you replace your Emission shader with a Principled Volume with non-zerodensity and the Noise connected to the Emission Strength you actually get different results (due to Start/End being interpreted differently) depending on whether Density is zero or non-zero. I'll raise it with the developers when I get the chance. $\endgroup$ Feb 10 at 9:41
  • $\begingroup$ I also loaded up a demo from Curtis Hold. Nebula demos he made were nice in Evee a while ago. Now they don't work properly. I think something changed and its why I am not getting the results as expected. I also have a different GPU than others have which may or may not be an issue. $\endgroup$ Feb 10 at 9:48
  • $\begingroup$ Going to do a purge of blender and do a fresh install. Could be a bad plugin or addon. $\endgroup$ Feb 10 at 9:56

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.