1
$\begingroup$

Material viewport displays Render and Render shows Solidrender preview and exported render display solid view of objects

I am running Blender 2.91.2 on Ubuntu 20.10 'Groovy' using Cycles with graphics card GTX 1070 (driver version 460.32.03, CUDA Version 11.2)

The top Viewport image (in the Animation tab) is meant to be the Material view but reflections have been rendered, the second image is under the Rendered view which displays only Solid properties. I have not used Blender for years but it seems that selecting 'Rendered' shows 'Solid', and selecting 'Material Preview' shows 'Rendered', and selecting 'Solid' shows 'Material Preview'.

The viewports are not as important as the actual render, which I run from the command-line after closing blender.

$ blender --background 333puzzleArray-6-short4render.blend -a produces an animated solid view, uploaded to https://youtu.be/NPvrTFzeML8

$\endgroup$
2
  • $\begingroup$ I can't see which one you have selected. Is your solid the first one, material second and the rendered last one. If so then there is nothing wrong it might be because the settings from the old version to the new version has been changed. Thanks. $\endgroup$ – Lawrence AS Feb 9 at 15:34
  • $\begingroup$ Thank you for asking. The order in the Animation viewports is Wire | Solid | Material | Render, I will add another screenshot. $\endgroup$ – Jay Wilson Feb 9 at 15:42
2
$\begingroup$

What is happening is that material shading, by default, uses a pre-supplied HDRi image as the world (that is why you see some trees and blue skies reflected on the glossy surfaces).

Rendered shading uses the actual settings for the scene, by default just a flat color.

You can set material view to use the actual scene lights and world.

enter image description here

Or you can set an HDRi to be used as environment texture on the world and that would be used for rendered view and to render the scene as well.

enter image description here

$\endgroup$
1
  • $\begingroup$ No improvements in the render output yet. I have added two walls, an area light and increased the ray path bounces through transparency (the blocks are clear acrylic in real life) but the rendered video remains the same. My Viewport shading options differ from the gif, I will keep experimenting. $\endgroup$ – Jay Wilson Feb 9 at 23:08

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.