2
$\begingroup$

This is a follow up to this post:

Cycles Textures not showing with shading - Works in Eevee

This is a similar problem. For some reason the translucent shader is not working properly in cycles:

Eevee vs Cycles Hat

Note, from left to right, it is Eevee, Cycles with the same light settings, and then Cycles with the point light turned down to 1W and no environment.

I have mixed translucency with the BSDF principled shader a more diffuse effect from the particles but it is acting a bit like a weak emitter. Also, you can see that the lens of the eye piece is emitting as well. There is no translucency set for that - it is just a simple image texture and principle BSDF shader. It ought to be completely in shadow.

For absolute sure, I am missing a simple setting somewhere. The Eevee version is what I ought to be seeing, but a little bit more realistically in cycles. What am I missing?

PS...I don't know if it is related, but Cycles is also ignoring the background when rendering. It is displaying a white background. (Blender 2.91.2)

Edit - I created a new blend file and appended the collection. I could not get the background to work properly in the original blend file. Once imported into the new blend file everything worked as expected. If any one knows if there might be seetting - I leave them to answer, otherwise the solution is to reconstruct the blend file.

Edit 2 - I have subsequently worked in the new file and attempted do use the same process. I added simple shaders to a low poly object, and in cycles it is not displaying the lighting correctly. The hat that I brought across IS displaying correctly. Again in Eevee, the new object (a boot) is displaying correctly. I cannot figure this out.

$\endgroup$
2
$\begingroup$

The answer to this is the "Ambient Occulsion" option in the world settings. If this is switched on, it is displaying the object "incorrectly" from the POV of what I would expect. Obviously, Eevee and Cycles handle AO differently. If anyone has anything else to add I would appreciate it (trying to learn here), but otherwise this was what was the cause of my issues.

$\endgroup$
3
  • 1
    $\begingroup$ Ambient occlustion is a way of fake shading to aproximate shading close to where objects touch each other. In cycles there is no need to fake shading as it the engine tries to resemble the way light works in the real world and the shading is calculated by how light rays bounce on the scene. Ambien Occlusion in cycles can be used though to simulate dirt and smugdes. $\endgroup$ – susu Feb 8 at 19:23
  • 1
    $\begingroup$ @susu There is an "Ambient Occlusion" setting in the World properties that can be used to uniformly (and not realistically) light the entire scene. Though there is a "Distance" setting (which can be negative) that somehow has an impact on contact shadows $\endgroup$ – Gorgious Feb 8 at 20:19
  • $\begingroup$ Thank you both. Susu - you recall the previous post about this - this would have been the same problem. Is there a default setting different in the way Blender handles world settings from previous versions? Because I don't recall having this issue before recently. I think Ambient occlusion got turned on for Cycles when switching to Eevee...I guess I'll have to check. I now know to switch off AO for world settings in Cycles. Phew. This really had me tearing my hair out. $\endgroup$ – DrIgnatiusCole Feb 9 at 11:21

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.