0
$\begingroup$

Suddenly, after trying some weird effects, shadings and deleting them, my object started displaying in the viewport as only mesh, disappearing in the camera but still renders completely fine.

I can't do further work without previewing.

Any guess on this?

objectscrewed

Edit: For clarification, this is the normal Animation view, I didn't change anything from the default windows organization. Also I'll include another screenshot for you to see that it's not about the object position or anything.

blender screwed

$\endgroup$
2
  • $\begingroup$ Is the left side of the screen the rendered view seen through the camera? Just a guess because it's hard to tell if there are any settings wrong, but in the 3D viewport on the right side it looks like the camera is behind the objects and therefore needs to be either looking in the opposite direction or move backwards to have the text in front again. //EDIT: Forget that, I guess than they wouldn't render in front of the camera. But on the other hand, the rendered frame is #173, the current view is at frame #1 and the text object is animated. Maybe the camera can't "see" the text on frame #1? $\endgroup$ – Gordon Brinkmann Feb 8 at 13:22
  • $\begingroup$ It's not that, and the windows are the default ones, I'm pretty noob at this so I didn't change any window organization, it's the default animation tab window config. I added another screenshot so you can tell it's not the keyframe position Thanks in advance $\endgroup$ – Tiago Mesquita Feb 8 at 16:36
1
$\begingroup$

Maybe you have accidentally deactivated something in the Object Types Visibility settings in the left 3D Viewport, for example Mesh or Text or anything else which applies to your text object. In this case it won't be displayed in the viewport but renders normal.

hidden object

$\endgroup$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.